Bug 28059 - [patch] Segfault and flames adding a "button" to the sheet
Summary: [patch] Segfault and flames adding a "button" to the sheet
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnumeric   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-16 23:24 UTC by Chris Evans
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-08 10:29:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnumeric-button.patch (550 bytes, patch)
2001-03-29 17:54 UTC, Tim Waugh
no flags Details | Diff

Description Chris Evans 2001-02-16 23:24:00 UTC
Hi,

This bug applies to adding a button (or most of the other widgets) to
a gnumeric sheet.

To reproduce

- Click on the "button" button.
- Click on the sheet. NOTE: Do not drag, just click once and release
quickly.

The app will die.

There is no crash if you click, drag and release. The button or other
widget
appears as expected if you do this.

Comment 1 Glen Foster 2001-02-17 22:38:05 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #2

Comment 2 David Mason 2001-02-19 16:11:32 UTC
Please explain this in more detail - what do you mean the "button" button. Are
you somehow adding a button to the actual spreadsheet? If so, how (step me
through the procedure). Also please give me the output of $rpm -q gnumeric - Thanks

Comment 3 Chris Evans 2001-02-19 22:22:43 UTC
[chris@localhost chris]$ rpm -q gnumeric
gnumeric-0.61-3
.
OK, fire up gnumeric.
From the top down, the toolbars go:
1) Menu strip
2) Toolbar 1
3) Toolbar 2
4) Toolbar 3

The third button in on toolbar 3 is the "button" button.
To confirm it is the correct button, hover over it and the following tooltip
should appear:
"Creates a button"

Comment 4 David Mason 2001-02-19 23:00:34 UTC
OK thanks - much clearer now :) assigning

Comment 5 Tim Waugh 2001-03-29 17:54:43 UTC
Created attachment 14123 [details]
gnumeric-button.patch

Comment 6 Tim Waugh 2001-03-29 18:47:34 UTC
Fixed package in ~twaugh/fixes/gnumeric-0.61-10.src.rpm.


Comment 7 Tim Waugh 2001-06-08 10:29:02 UTC
I've removed this file now, but the patch is still here for someone to 
integrate..


Comment 8 Owen Taylor 2001-07-19 22:30:32 UTC
Seems to be fixed as of 0.67.


Note You need to log in before you can comment on or make changes to this bug.