Bug 2807 - Raid Tools corrupts kernel memory and doesn't function correctly on at least SPARC architecture.
Raid Tools corrupts kernel memory and doesn't function correctly on at least ...
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Depends On:
  Show dependency treegraph
Reported: 1999-05-13 23:24 EDT by dws
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-16 09:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description dws 1999-05-13 23:24:29 EDT
I tried to get both Linear and Raid 0 running on a Sun
SparcStation LX with 24 Megabytes of memory and three SCSI
hard drives.  I tested each drive separately and they all
worked fine.  When I tried to do a mkraid /dev/md0 (after
loading the linear and raid0 modules and setting up the
examples listed in the docs) the machine
started doing very strange things (like VI couldn't find
a symbol in the libc shared library).  The mkraid command
returned an "invalid argument /dev/md0" error message and
a lot of kernel raid debugging messages printed out from the
kernel.  I then grabbed the latest version of
raidtools-19990421-0.90 from
the listed site and was able to get raid0 working but not
linear mode. (Please see my other bug report on the
initscripts package having to do with loading modules before
the raidstart command is run).  Please let me know if I can
do any other specific tests that would help with the
Comment 1 Viraj Alankar 1999-07-22 09:03:59 EDT
I was not even able to mkraid on my sun4m. It sends a kernel messages
'Unimplemented SPARC system call 140'. After looking through the
latest source, I defined __usparc__ in raid_io.c, recompiled, and was
able to mkraid. Then strange things happened such as not being able to
execute /bin/vi (cannot execute binary file).
Comment 2 Elliot Lee 2001-07-16 14:49:39 EDT
Closing ancient bug, please reopen if still relevant on !sparc in current
release (7.1).

Note You need to log in before you can comment on or make changes to this bug.