Bug 280801 - Evolution shows attachment icon even if there's isn't any
Evolution shows attachment icon even if there's isn't any
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 11:43 EDT by Michal Babej
Modified: 2013-07-31 19:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 05:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Babej 2007-09-06 11:43:12 EDT
Description of problem:
Evolution shows attachment icon even if the email has no attachments. I guess
it's caused by the fact that the message in question has "Content-Type:
multipart/mixed;" but actually only contains 1 part (text/plain), properly
enclosed in boundaries. It's a bit misleading.

Version-Release number of selected component (if applicable):
evolution-2.10.3-2.fc7
evolution-data-server-1.10.3.1-2.fc7
evolution-webcal-2.10.0-1.fc7
evolution-data-server-devel-1.10.3.1-2.fc7

How reproducible:
always
Comment 1 Matthew Barnes 2007-09-06 12:37:23 EDT
Can you post an mbox file containing such an email?
Comment 3 Matthew Barnes 2007-09-06 15:43:00 EDT
Thanks Michal, easily reproducible.

I found the logic that decides whether to display the icon:

        ml_tree_value_at() (in message-list.c):

        case COL_ATTACHMENT:
                return GINT_TO_POINTER (
                        (camel_message_info_flags(msg_info) &
                         CAMEL_MESSAGE_ATTACHMENTS) != 0);

It's just checking a flag, so that's okay.  The bug, then, must be in Camel. 
I'll keep digging...
Comment 4 Matthew Barnes 2007-09-06 15:50:35 EDT
You're right, Camel is just setting the CAMEL_MESSAGE_ATTACHMENTS flag based on
whether the MIME type is "multipart/mixed" (in camel-folder-summary.c).  I guess
it should also check whether the number of parts is > 1.  I need to consult with
upstream.
Comment 5 Milan Crha 2008-02-12 05:58:53 EST
Moving this upstream to bug [1]. We will track it there.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=478239

Note You need to log in before you can comment on or make changes to this bug.