This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 280861 - Kernel panic after issuing a pair of commands (needs root user)
Kernel panic after issuing a pair of commands (needs root user)
Status: CLOSED DUPLICATE of bug 236880
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michal Schmidt
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 12:16 EDT by Jordi Sanfeliu
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 09:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordi Sanfeliu 2007-09-06 12:16:55 EDT
Description of problem:
First of all, I'm not using RHEL5 but CentOS5. People under the IRC #centos
channel suggested me to file a bug directly to RedHat due the severity of the
problem. So that's why I'm here.

The problem was encountered by a mistake trying to link a loop device to a
file using the mount command instead losetup, and then after the expected
error message from the mount command, I changed mount by losetup and just
after press Enter the system freezes.

NOTE: maybe the mount and losetup steps need to be completed two times to
generate the kernel panic.

I've reproduced the problem under different machines using the same up to date
CentOS 5 system with the same results.



Version-Release number of selected component (if applicable):
mount --version says:
mount (util-linux 2.13-pre7)



How reproducible:
Always, maybe need two passes instead only one in some machines.



Steps to Reproduce:
The following are the steps to reproduce the problem:
(other steps may reproduce the problem too, but to make sure use theses ones)

1) Download the floppy boot image from here:
http://archive.download.redhat.com/pub/redhat/linux/7.3/en/os/i386/images/boot.img

2) Convert it to a cdrom boot image using the following command:
mkisofs -R -b boot.img boot.img > boot-cdrom.iso

3) mount /dev/loop0 boot-cdrom.iso
(it will display a normal error message here)

4) losetup /dev/loop0 boot-cdrom.iso

It must panic here, otherwise do a "losetup -d /dev/loop0" and go to step 3.


  
Actual results:
Kernel panic - not syncing: Fatal exception



Expected results:
The command should work finely.



Additional info:
Comment 2 Michal Schmidt 2007-09-24 09:22:29 EDT
I could reproduce the crash with 2.6.18-8.1.8.el5, but not with a current
development build. The issue looks similar to bug 236880. Possibly fixed already.
Jordi, can you test a recent kernel development build from
http://people.redhat.com/dzickus/el5/ ?
Comment 3 Jordi Sanfeliu 2007-09-25 02:21:29 EDT
I have just upgraded my CentOS 5 to the very last kernel 2.6.18-8.1.10.el5 and
the kernel panic still persist.

Remember that it may need two passes before see the panic (steps 3 and 4)
Comment 4 Michal Schmidt 2007-09-25 03:33:47 EDT
2.6.18-8.1.10.el5 does not have the fix for bug 236880. Can you please test a
newer kernel from http://people.redhat.com/dzickus/el5/ ? E.g. version 49.el5.
Thanks.
Comment 5 Jordi Sanfeliu 2007-09-25 09:34:17 EDT
Ok, I have tested it with the kernel 2.6.18-49.el5 and it works finely. As you
said the problem was probably fixed.

I tried a lot of passes even I've executed a shell-script with the steps 3 and 4
inside a while [ 1 ] loop during several minutes, and the panic was not seen.

I think you can close this issue.

Thanks.
Comment 6 Michal Schmidt 2007-09-25 09:39:08 EDT

*** This bug has been marked as a duplicate of 236880 ***

Note You need to log in before you can comment on or make changes to this bug.