This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 280941 - Querying of IPv6 does no longer work
Querying of IPv6 does no longer work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-06 12:58 EDT by Robert Scheck
Modified: 2007-12-06 07:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 07:23:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed fix (2.13 KB, patch)
2007-12-04 11:21 EST, Lubomir Kundrak
no flags Details | Diff

  None (edit)
Description Robert Scheck 2007-09-06 12:58:41 EDT
Description of problem:
Querying of IPv6 does no longer work, try yourself:

> whois 2001:620::5
[Abfragen von whois.iana.org]
[whois.iana.org]
Domain  not found.  Please note that this whois server
only provides information for a very few domains.

>

We've currently a regression, please make whois'ing IPv6 working again.

Version-Release number of selected component (if applicable):
jwhois-4.0-2

How reproducible:
Everytime, see above.

Actual results:
Querying of IPv6 does no longer work

Expected results:
IPv6 working again, like in the past ;-)
Comment 1 Robert Scheck 2007-10-21 16:56:01 EDT
Ping?
Comment 2 Vitezslav Crhonek 2007-11-07 07:51:50 EST
Hi,

I investigated it, but can't find out where the problem is - jwhois.conf is up
to date, right address is taken...

Another point - you closed #230001 as working in 4.0-1 - does it still work for
you? 4.0-2 is same as 4.0-1 (only fixed license and maybe cache not disabled by
default, IIRC), so if it all worked in 4.0-1 I wonder why it doesn't work now:(
Comment 3 Robert Scheck 2007-11-07 09:31:20 EST
Wrong address is taken. IANA is queried instead of RIPE. So the lookup within 
the configuration file seems to fail somewhere...
Comment 4 Robert Scheck 2007-11-07 09:33:17 EST
Bug #230001 works further on as expected.
Comment 5 Lubomir Kundrak 2007-12-04 10:16:00 EST
This matches 2001:0620::5 and it obviously shouldn't:

        "2001:0000::/23" = "whois.iana.org";
Comment 6 Lubomir Kundrak 2007-12-04 11:21:08 EST
Created attachment 277131 [details]
Proposed fix

I think I found that. Robert: you seem to use whois extensively -- could you
please look if it doesn't break something for you (if we don't rely on the
wrong matching somewhere, etc.)
Comment 7 Robert Scheck 2007-12-05 18:37:25 EST
Lubomir, you're good - the fix works. I'll test the patch the next few days
during regular work. And yes, I'm using whois much times a day, but this is
normal when working for a company which is also an ISP ;-)

Note You need to log in before you can comment on or make changes to this bug.