Bug 281031 - Upgrade fails - anaconda crashes
Upgrade fails - anaconda crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 13:44 EDT by Gary Thomas
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 10:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash log (115.00 KB, text/plain)
2007-09-06 13:44 EDT, Gary Thomas
no flags Details

  None (edit)
Description Gary Thomas 2007-09-06 13:44:41 EDT
Description of problem:

Trying to upgrade to FC7, but didn't have enought (1.1GB) space
for the process.  This was reported and I rebooted the extant 
system to find some space.  When I restarted the upgrade it failed
right away with an anaconda crash.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Try to upgrade a system with insufficient space.
2. Reboot & make space
3. Retry the upgrage
  
Actual results:


Expected results:


Additional info:

The problem is that once the upgrade is underway, the file 
'/etc/modprobe.conf' is renamed on the target system to allow
anaconda to build/install a new one.  If the upgrade fails, then
this file is left missing which gives the upgrade tool fits the
next time around.

Once I figured this out, I booted the extant system and copied the
saved version.  Restarting the upgrage process then succeeded.
Comment 1 Gary Thomas 2007-09-06 13:44:41 EDT
Created attachment 189021 [details]
anaconda crash log
Comment 2 Chris Lumens 2007-09-07 10:24:52 EDT
This will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.