Bug 281061 - gnash fails when wrapped, works when native
gnash fails when wrapped, works when native
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 13:47 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.8.1-6.fc8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:39:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mkanat: fedora_requires_release_note?


Attachments (Terms of Use)
proposed gnash patch (1.07 KB, patch)
2007-10-15 05:37 EDT, Martin Stransky
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2007-09-06 13:47:47 EDT
Description of problem:

When wrapped with nspluginwrapper, the gnash plugin aborts immediately; it seems
to work OK when not wrapped.

Version-Release number of selected component (if applicable):

gnash-plugin-0.8.1-2.fc8
nspluginwrapper-0.9.91.5-1.fc8

How reproducible:

Every time

Steps to Reproduce:
1. install gnash-plugin
2. attempt to waste time on youtube
  
Actual results:

Empty gray plugin-did-not-initialize boxes.

Expected results:

Silly videos.
Comment 1 Martin Stransky 2007-09-10 07:48:23 EDT
Hm, both (wrapper and unwrapped) versions of gnash crash for me. You you have
any favorite clip / flash page what works with gnash fine?
Comment 2 Bill Nottingham 2007-09-10 13:49:03 EDT
Other than 'youtube', not really. interactive flash things didn't work very well.
Comment 3 Martin Stransky 2007-09-11 03:24:32 EDT
Wrapper and unwrapped gnash work for me on some flash sites but both crashes
periodically....
Comment 4 Deji Akingunola 2007-09-24 09:43:17 EDT
Wrapped gnash plugin crashes here too, while unwrapped one works just fine (no
crashes), e.g. http://www.anandtech.com/
Comment 5 Deji Akingunola 2007-10-10 08:49:28 EDT
Is there any particular benefit to wrapping the gnash plugin (it builds natively
on all Fedora supported archs)? Please add it to the exclude list as was done
for totem.
Comment 6 Martin Stransky 2007-10-10 09:04:50 EDT
I just work on this issue... All possible plugins should be wrapped because of
security/browser stability issues.
Comment 7 Martin Stransky 2007-10-15 05:37:01 EDT
Created attachment 227421 [details]
proposed gnash patch

This bug is caused by gnash - it calls the original mozilla(or wrapper) code
after fork from the child process.
Comment 8 Patrice Dumas 2007-10-15 06:48:57 EDT
I have forwarded the mail on gnash mailing list for
review there.
Comment 9 Patrice Dumas 2007-10-15 19:11:02 EDT
It is on gnash cvs. It would be nice if you could test
there.
Comment 10 Patrice Dumas 2007-10-27 19:41:37 EDT
I have pushed the F-8 build to testing.

I tried to add both F-7 and F-8 builds in bodhi, but it didn't worked
and now bodhi doesn't want ti create an updae for F-7 so there won't
be an F-7 update.
Comment 11 Max Kanat-Alexander 2007-11-03 10:46:09 EDT
With rawhide as of today, gnash doesn't even show up in about:plugins unless I
entirely remove nspluginwrapper. This should probably either be resolved or
something should be noted in the relnotes, since they currently mention gnash.
Comment 12 Fedora Update System 2007-11-06 11:03:48 EST
gnash-0.8.1-6.fc8.1 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnash'
Comment 13 Karsten Wade 2007-11-12 21:18:51 EST
What is the conclusion about release notes?  Is one needed?

If so, the wiki is open for the next few weeks at
http://fedoraproject.org/wiki/Docs/Beats.  If you let us know via this bug
report, one of the Docs folks can put in a note.  Details or suggestions for the
note are welcome. :)
Comment 14 Patrice Dumas 2007-11-13 03:36:18 EST
(In reply to comment #11)
> With rawhide as of today, gnash doesn't even show up in about:plugins unless I
> entirely remove nspluginwrapper. This should probably either be resolved or
> something should be noted in the relnotes, since they currently mention gnash.

I cannot reproduce with gnash-plugin.i386 0:0.8.1-6.fc9. It shows
the plugin in about:plugins. And it even works.

Nobody has tested the F-8 version, as far as I know but I am not 
sure that testing is easy for now.

As a side note what is mentioned in the release notes? I cannot
find a searchable page (that is all in one page) starting from
the main release notes location. 
Comment 15 Fedora Update System 2007-11-26 13:39:42 EST
gnash-0.8.1-6.fc8.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.