Bug 281111 - Pulse daemon fails to start in RHEL4U5.
Pulse daemon fails to start in RHEL4U5.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 14:11 EDT by Gowrishankar Rajaiyan
Modified: 2009-04-16 16:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHGFS4-QU4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 08:26:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvs.cf configuration file attached. (609 bytes, text/plain)
2007-09-06 14:11 EDT, Gowrishankar Rajaiyan
no flags Details

  None (edit)
Description Gowrishankar Rajaiyan 2007-09-06 14:11:03 EDT
Description of problem: Pulse daemon fails to start in RHEL4U5.


Version-Release number of selected component (if applicable): 0.8.0-1


How reproducible: Always.


Steps to Reproduce:
1. Copy the attached lvs.cf on Director (RHEL4U5) and Backup (RHEL5) balancers.
2. service pulse start
3. tail -f /var/log/messages
  
Actual results: Starting pulse: pulse: error parsing /etc/sysconfig/ha/lvs.cf at
line 7: unknown command

tail -f /var/log/messages
Sep  1 23:23:04 director pulse: pulse: error parsing /etc/sysconfig/ha/lvs.cf at
line 7: unknown command
Sep  1 23:23:04 director pulse: pulse startup failed
Sep  1 23:23:04 director pulse: pulse: error parsing /etc/sysconfig/ha/lvs.cf at
line 7: unknown command
Sep  1 23:23:04 director pulse: pulse startup failed
Comment 1 Gowrishankar Rajaiyan 2007-09-06 14:11:03 EDT
Created attachment 189051 [details]
lvs.cf configuration file attached.
Comment 2 Gowrishankar Rajaiyan 2007-10-22 05:53:55 EDT
I used the following rpms:

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/RHCS/i386/SRPMS/ipvsadm-1.24-6.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/RHCS/i386/SRPMS/piranha-0.8.0-1.src.rpm

The option monitor_links does not seem to be supported by Piranha 0.8.0-1 on
RHEL4.  This option seems to be new in later versions of Piranha.
Comment 3 Marek Grac 2007-10-30 07:28:16 EDT
I have tried your configuration files with current version of piranha (0.8.3-x)
and I don't have these problem. Can you try to download newer version of piranha
from: ftp://ftp.redhat.com/pub/redhat/linux/updates/enterprise/4AS/en/RHCS/SRPMS/ ?
Comment 5 Gowrishankar Rajaiyan 2008-01-17 21:25:50 EST
Current version of piranha does not have this problem.

Note You need to log in before you can comment on or make changes to this bug.