Bug 281291
| Summary: | Option ExecCGI not allowed in <Perl> configuration section | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 5 | Reporter: | Trevin Beattie <tbeattie> |
| Component: | mod_perl | Assignee: | Joe Orton <jorton> |
| Status: | CLOSED DUPLICATE | QA Contact: | |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 5.0 | ||
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2007-09-25 16:28:14 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Description of problem: "Options => 'ExecCGI'" is rejected in a <Perl> section in contexts where "Options ExecCGI" is normally allowed. Version-Release number of selected component (if applicable): mod_perl-2.0.2-6.1 (with httpd-2.2.3-6.el5) How reproducible: Always Steps to Reproduce: 1. Create a .conf file containing: <Perl> $Directory{"/var/www/cgi-bin"} = { Options => 'ExecCGI', }; </Perl> 2. Run "service httpd configtest". Actual results: Syntax error on line 6 of /etc/httpd/conf.d/mod_perl_bug.conf: $parms->add_config() has failed: Option ExecCGI not allowed here at /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Apache2/PerlSections.pm line 203.\n Expected results: Syntax OK Additional info: The following configuration does not result in an error: <Directory "/var/www/cgi-bin"> Options ExecCGI </Directory> This bug has been reported for other distributions: http://wiki.mozilla.org/Bugzilla:FAQ:Software_Matrix#Apache http://www.mail-archive.com/debian-bugs-closed@lists.debian.org/msg140739.html The solution in both cases was to upgrade to mod_perl 2.0.3 or higher.