Bug 28131 - ntsysv should require root to run
Summary: ntsysv should require root to run
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkconfig   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-17 06:05 UTC by Jeremy Katz
Modified: 2014-03-17 02:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 19:10:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2001-02-17 06:05:25 UTC
All of the rest of the *config programs require that you be root to run
them giving an error message if you are not root.  ntsysv should probably
do the same.  Alternately, on exit, ntsysv shouldn't try to set up which
services should run to avoid the slew of error messages due to permission
denied

Comment 1 Preston Brown 2001-02-17 21:30:36 UTC
this was changed as of ntsysv-1.2.21 and later.


Note You need to log in before you can comment on or make changes to this bug.