Bug 28133 - Install fails upon package selection start - restart machine only option
Install fails upon package selection start - restart machine only option
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 06:46 EST by Jez Tucker
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 11:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jez Tucker 2001-02-17 06:46:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


I'm trying to install 7.0 Pro Server with Workstation auto setup on my
computer.
On one of my HD's I have a copy of NT 4.0.
On the one I'm installing over is an old copy of RH 6.1.
I get through the installation until the package selection whereby anaconda
crashes (see Actual Results).  
I've tried it in text, linux and linux updates mode

Reproducible: Always
Steps to Reproduce:
1. Insert RH 7.0 Boot diskette
2. Do: linux updates (using update-disk-20001009)
3. Select language (english).
4. Select PC layout (Generic 101, UK, Enable dead keys)
5. Select Mouse (generic 3 button PS/2)
6. Select Workstation install
7. Select Auto partiton and remove data
8. Select GMT London Timezone
9. Enter root passwd and setup user
10. Reads package info.
11. Exceptional condition (crash) occurs
	  

Actual Results:  An exceptional conditon has occurred.  (yada yada yada)

Traceback (innermost last):
File "/usr/bin/anaconda", line 438, in ?
  intf.run(todo, test = test)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
self.icw.run ()  
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
mainloop ()
File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
_gtk.gtk_main()
File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__ ret =
apply(self.func, a)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked self.setScreen (self.currentScreen, self,nextClicked)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 463, in
setScreendirection ()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClickedself.setScreen (self.currentScreen, self.nextClicked)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py, line 466, in
setScreennew_screen = screen.getScreen ()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package/package_gui.py,
line 427, in getScreenself.todo.getCompsList()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsListself.comps = self.method.readComps(self.hdList)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in
readComps return ComponentSet(self.tree + 'RedHat/base/comps', hdlist)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__ self.readCompsFile(file, self.packages, arch, matchAllLang)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile comp.addpackage(packages[l])
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__ return self.packages[item]
KeyError: MAKEDEV


Expected Results:  The installer should have installed all my packages

My Machine:

2* P133 (AST Premmia GX)
112MB RAM
2 * Internal SCSI drive, 1 * Int SCSI cdrom (ncr53c8xx driver)
2 * Matrox Millenium II 4MB (going for dual heads)
1 * Soundblaster AWE32 
Onboard AMD1400L NIC(Anyone know of a driver for this?)
Comment 1 Michael Fulbright 2001-02-20 14:35:37 EST
Was this a hard drive or CD based install?

In either case you are either missing required files, or have a bad CD.
Comment 2 Jez Tucker 2001-02-21 07:41:18 EST
This was  CD based install that has succeeded on approximately 20 other various
INTEL based machines to date (from the exact same CD).
Comment 3 Michael Fulbright 2001-02-21 18:21:12 EST
I would suspect the CDROM drive itself then.
Comment 4 Jez Tucker 2001-02-22 04:56:12 EST
The CD-ROM drive H/W is 100% OK. (Being a standard ATAPI IDE unit)

I can happily install RH 4.1, 4.2, 6.0, 6.1, Win9x, NT using the drive.

I shall install another CD-ROM drive just to absolutely confirm any conflict
etc. (maybe a driver issue?)

I notice you have changed the bug to RESOLVED.  Why was this done without
confirming your assumption?
Comment 5 Jez Tucker 2001-02-22 05:00:52 EST
Sorry - as before drive is not atapi. - I'll try with an ATAPI unit.
Comment 6 Changed to DavidTangye@hotmail.com 2001-02-23 03:36:28 EST
I get the same error when attempting a Hard disk install.

The install finds the distribution in the RedHat directory, and I select to run a Custom 
install, create new partitions for / and swap, select mouse, timezone and initial 
users/passwords, select authentication options Shadow password on, MD5, NIS, LDAP 
Kerberos off. Install reports "Reading package information" and very soon after I get the 
failure and the Anaconda dump file as follows.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __getitem__
KeyError: indexhtml

Local variables in innermost frame:
self: <comps.HeaderList instance at 8253728>
item: indexhtml

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 7 Changed to DavidTangye@hotmail.com 2001-02-23 03:47:29 EST
Additional background to my previous posting.
It seems by previous msgs in this bug that I am missing a file.
If so can't we tell which file it is by looking in the dump as shown in my previous posting?

Further background info is :

I downloaded most of the dosutils, images and RedHat directories, but not the 
RedHat/instimages because I read it is only for NFS installs. The files are on a Win32 
partition, so Linux install will see it. There are 869 files in RPMS, so I think I got the 
entire RPMS distribution. Can anyone confirm this. All files in there are dated 
28 or 30 Aug 2000.

I used dosutils/rawrite to set up a boot disk from images/boot.img.
I then attempted the Hard disk install as per the previous posting.
Comment 8 Michael Fulbright 2001-02-27 18:46:58 EST
The only way this failure can occur is if the file was not read from the CD. You
can check on VC3 and VC4 (cntl-alt-f3 and -f4) to see if there are read errors
from the CD.

Comment 9 David Tangye 2001-03-06 23:45:18 EST
Well I am happy to say that this is now coming via Netscape under RH7. I got a
CD and booklet from the local newsagents for $15, and did a CD install last week
- several installs actually, just to try things :-).
However I still do not know why the original install failed and am a bit
concerned that :

 - VC3, 4 etc showed nothing
 - the error message was not clear
  - you folk could not tell me what the problem file was.

I guess I get to work it out myself one day.
Comment 10 Michael Fulbright 2001-04-02 11:47:14 EDT
I am sorry for the original issues you encountered. I am happy you were able to
get your system installed in the end.  We are continually adding new exception
handling to the installer so there are fewer and fewer mysterious crashes like
you encountered.

I am closing this as 'RAWHIDE', which basically means it works now.

Note You need to log in before you can comment on or make changes to this bug.