This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 281461 - pulseaudio grew by a lot
pulseaudio grew by a lot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker F8Test3
  Show dependency treegraph
 
Reported: 2007-09-06 17:22 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 06:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-09-06 17:22:55 EDT
From pulseaudio-0.9.7-0.8 -> pulseaudio-0.9.7-0.10, the packages grew by a very
significant amount thus making things not fit for live CDs.  

It looks like this is because libpulsecore is now getting statically linked into
every module rather than a dynamic link.  That means that every module is ending
up with the 322k shared library included within it.
Comment 1 Jeremy Katz 2007-09-06 17:32:15 EDT
Due to http://www.pulseaudio.org/changeset/1755

Even if libpulsecore doesn't have a stable API, it's still worth installing a
shared lib.  Just don't include a .so link or any headers and people will at
least have to try to use it.  And/or include it in /usr/lib/pulse-0.9 and link
things with an rpath. 

But just linking things statically is far far worse.
Comment 2 Lennart Poettering 2007-09-07 06:06:31 EDT
It's all libtool's fault.

Fixed in the Rawhide commit I did today in the early morning CEST.

Note You need to log in before you can comment on or make changes to this bug.