Bug 281761 - Pirut via puplet crashes with problems related to resolving dependencies on vlc
Pirut via puplet crashes with problems related to resolving dependencies on vlc
Status: CLOSED DUPLICATE of bug 253394
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 21:32 EDT by Francis Shim
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 10:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report as observed from updating with pirut and the puplet applet (1.77 KB, text/plain)
2007-09-06 21:32 EDT, Francis Shim
no flags Details

  None (edit)
Description Francis Shim 2007-09-06 21:32:38 EDT
Description of problem:
  While performing a routine update of Fedora via the puplet applet and pirut,
the update crashed while trying to resolve dependencies.  The text of the error
messages have been attached as requested.

Version-Release number of selected component (if applicable):
  pirut-1.3.9-1.fc7

How reproducible:
  When using the default applet, puplet and pirut to simply update Fedora 7 the
problem always reproduces itself.  I have narrowed the scope of the bug to be
reproducible whenever there is a package in the update set that has some
dependency on the "vlc" package set.  Please see the attached error text for
more insight.

Steps to Reproduce:
1.  Have some package in the update set as one having a dependency on "vlc"
2.  Execute the update either through puplet and pirut or using yum
3.  Python will eventually yield the error messages
  
Actual results:
  Please see the attached

Expected results:
  Either a successful update or an error report from yum that indicate problems
with Dependency Resolutions.

Additional info:
  Please see attachment.
Comment 1 Francis Shim 2007-09-06 21:32:38 EDT
Created attachment 189411 [details]
Bug report as observed from updating with pirut and the puplet applet
Comment 2 Francis Shim 2007-09-06 22:44:17 EDT
The packages that were giving problems were flac and x264.

However, using yum I updated yum-updatesd to the latest version (3.2.4-2.fc7)
and the problem has been resolved.  It appears that the problem has more to do
with the way the dependency lists are accessed via the python modules.

I will leave the status alone until someone can reassign it to a more
appropriate category.

Thanks,
Frank
Comment 3 Jeremy Katz 2007-09-07 10:58:55 EDT

*** This bug has been marked as a duplicate of 253394 ***

Note You need to log in before you can comment on or make changes to this bug.