Bug 281871 - drop requires xorg-x11-fonts-ISO8859-1-75dpi
drop requires xorg-x11-fonts-ISO8859-1-75dpi
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 01:01 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 12:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-09-07 01:01:23 EDT
Description of problem:
Can xemacs drop the requires xorg-x11-fonts-ISO8859-1-75dpi
since it already requires xorg-x11-fonts-ISO8859-1-100dpi?
The 75dpi fonts are not being installed by default anymore in F8.
Comment 1 Ville Skyttä 2007-09-07 11:44:32 EDT
I don't know - at least on my F7 desktop with a 1680x1050 HP f2105 94x95dpi LCD
display, without changing anything else, removing the 75dpi fonts results in the
XEmacs fonts being *much* too large for my taste, ditto the initial window size.
 Removing the 100dpi fonts on the other hand did not seem to have any drawbacks
in this setup based on some quick tests.  FWIW, emacs depends on the 75dpi
fonts, but not the 100dpi ones.

Does F8 have some changes that would have an effect on this experience?  I don't
have a Rawhide box to test with, nor am I anywhere near a font expert to be able
to say for sure even if I had one (nor am I sure whether it counts that my setup
doesn't appear to have any problems with dropping the 100dpi dep).
Comment 2 Jens Petersen 2007-09-09 22:29:23 EDT
Okay - I filed this in connection with bug 254086,
but it is not such a big deal so feel free to close wontfix if you like.
(Some people might like the large window size but it is partly
a matter of taste and habit I suppose.:)
Comment 3 Ville Skyttä 2007-09-10 12:00:47 EDT
Ok, I'll leave it as is for now.  Hopefully Xft support in upstream XEmacs
reaches "production ready" status soon, at which point I guess dropping
dependencies on all bitmap fonts could be an option.

Note You need to log in before you can comment on or make changes to this bug.