Bug 28189 - the kernel upgrade forgets to upgrade lilo and deletes old image. The machine hungs after the upgrade for this reason.
Summary: the kernel upgrade forgets to upgrade lilo and deletes old image. The machine...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-17 21:56 UTC by Need Real Name
Modified: 2015-01-07 23:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 01:34:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-17 21:56:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4u)


I upgraded to the new kernel using up2date. After the upgrade the machine
didn't boot due to lilo pointing to the old boot image. This old image is
inexistent because the upgrade deletes it, is this necessary? 

Reproducible: Always
Steps to Reproduce:
1. upgrade to the new kernel using up2date and try to boot the machine
afterwards.
2.
3.
	

Actual Results:  the machine hungs

Expected Results:  the machine should boot the new kernel

Comment 1 Adrian Likins 2001-02-18 03:17:22 UTC
automatic kernel updates are currently not supported with up2date.
The kernel packages are specifically excluded for automatic
updating with up2date.

There is currently work going to add supports for automatically
installing kernel packages.  But for the time being, the kernel
packaeges should be installed manually.

Comment 2 Cristian Gafton 2001-02-20 01:34:25 UTC
Assigned QA to jturner

Comment 3 Preston Brown 2001-02-20 17:35:42 UTC
For this release, kernel upgrades with up2date are not supported.  That is why
kernel is in the excludes list.

This _may_ be supported in the next release, but it may not.  The engineering
behind it to make sure nothing fails is non-trivial.


Note You need to log in before you can comment on or make changes to this bug.