Bug 28192 - Install fails on custom install after authentication choice
Install fails on custom install after authentication choice
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 17:25 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 17:40:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-17 17:25:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)


I can not get past the Authentication screen on installation.  This is for a custom install on a PIII-866 512MB RAM
manually partitioned with LILO on boot partition.  This is on a disk (IDE) which includes Win2K Professional NTFS
on first 6GB of 20GB disk.

Reproducible: Always
Steps to Reproduce:
1. start CD based install
2. choose graphical install
3. choose custom
4. manually partition (/boot=16M  / =1000M  <Swap>=128M  /usr=1000M  /usr/local=1000M  /var=512M  /opt=256M)
5. choose format with disk scan
6. LILO config (create boot disk, install LILO on /dev/hda2, /=/dev/hda5 default boot image)
7. choose not to activate eht0 on boot
8. Time zone = US Central
9. set root password
10. add one user account
11. choose default MD5 and Shadow password on authentication screen
12. Install Crashes anacdump.txt provided

Actual Results:  Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line 427, in getScreen
    self.todo.getCompsList()
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __getitem__
    return self.packages[item]
KeyError: MAKEDEV

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 84ac7b0>
item: MAKEDEV

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

I even tried the October installer update image using "linux updates" at boot prompt on step 2 above.
Comment 1 Michael Fulbright 2001-02-21 11:25:33 EST
If you can mount the CD on a linux machine, try the command

rpm -K --nogpg /mnt/cdrom/RedHat/RPMS/MAKEDEV-*

and report the results.

Your CD is most likely bad.
Comment 2 Need Real Name 2001-02-22 15:10:47 EST
Here is the result from    rpm -K --nogpg /mnt/cdrom/RedHat/RPMS/MAKEDEV-*

    /mnt/cdrom/RedHat/RPMS/MAKEDEV-3.0.6-5.i386.rpm: md5 OK

FYI: This same CD was used to successfully upgrade another system.

Comment 3 Michael Fulbright 2001-02-23 12:21:05 EST
Did you run this command on the CD drive you were installing from?  The only way
I know that you can get the error you did is if the installer was unable to read
the RPM from the CD.
Comment 4 Need Real Name 2001-02-23 13:35:28 EST
I ran the rpm -K --nogpg /mnt/cdrom/RedHat/RPMS/MAKEDEV-* command from another
Linux system since I'm still unable to install Linux on this new system.  The system
with this installation problem has a DVD, if that makes any difference.  I'm booting from
the CD in the DVD drive and its obviously accessing it OK since it gets well into the
graphical install procedure before getting this error.
Comment 5 Michael Fulbright 2001-02-27 18:45:03 EST
It appears that the DVD device is having problems with the CD, or Linux is
having trouble using the DVD device instead of the CD drive in the other
machine. 

Is it possible to use a CD drive in the machine exhibiting problems?
Comment 6 Need Real Name 2001-03-01 23:00:57 EST
I downloaded a new ISO image for disk 1 and burned a new CD.  I was able to complete the
install with this new CD.  There must have been just a slight incompatibility with the first CD
and my DVD drive.  FYI: both CD's were burned on a Yamaha SCSI CD-RW on a Solaris
system with cdrecord but on different brands of CD-R's.  In addition the disk 2 from the original
set I burned worked just fine with my DVD drive.  Thanks for the help in narrowing down the
problem!
Comment 7 Michael Fulbright 2001-03-05 17:40:56 EST
No problem. I must see 5 or more CD related problems a day. I guess with all the
different types of CDR media there are more problems.

Note You need to log in before you can comment on or make changes to this bug.