Bug 28195 - poweroff halts system, then ctl-alt-del causes oops
poweroff halts system, then ctl-alt-del causes oops
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 17:53 EST by Ben Levenson
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 12:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dell PowerEdge lspci/lspci -n (1.65 KB, text/plain)
2001-02-22 12:11 EST, Ben Levenson
no flags Details
Dell PowerEdge dmesg (14.86 KB, text/plain)
2001-02-22 12:13 EST, Ben Levenson
no flags Details
Acer Altos lspci/lspci -n (1.06 KB, text/plain)
2001-02-22 12:13 EST, Ben Levenson
no flags Details
Acer Altos dmesg (12.94 KB, text/plain)
2001-02-22 12:14 EST, Ben Levenson
no flags Details

  None (edit)
Description Ben Levenson 2001-02-17 17:53:59 EST
build: qa0217.0
upgraded 7.0 system to 7.1

# poweroff
....
Unmounting file
systems:                                                        
Unmounting proc file
system:                                                    
The system is
halted                                                            
stopping all md
devices.                                                        
Power down.

(system does not powerdown)
type
CTL-ALT-DEL                                                                     

stopping all md
devices.                                                        
NMI Watchdog detected LOCKUP on CPU2,
registers:                                
CPU:   
2                                                                      
EIP:   
0010:[<c0209f62>]                                                       
EFLAGS:
00000097                                                                
eax: 4ea21ab1   ebx: 00079f2c   ecx: 4ea16b1b   edx:
00000038                   
esi: 00000000   edi: 00000001   ebp: c02ffe40   esp:
c213fe94                   
ds: 0018   es: 0018   ss:
0018                                                  
Process swapper (pid: 0,
stackpage=c213f000)                                    
Stack: 0000000d c01c076b 00079f2c c027ac78 c0122865 c027ac78 00000001
00000000         00000002 0000f20c 0000006f c0122da8 c02cfde4 00000001
00000000 c018d9d1         
c018d30e 0000000c 00000000 6f000020 00000000 00000053 0000270f c213e000  
Call Trace: [<c01c076b>] [<c0122865>] [<c0122da8>] [<c018d9d1>]
[<c018d30e>] [<        [<c0120776>] [<c018e5ec>] [<c010aa1e>] [<c010ac21>]
[<c0107290>] [<c0109        
[<c01072bc>] [<c0107342>]
[<c0118e95>]                                                                                                                   
Code: 29 c8 39 d8 72 f8 5b c3 8d b6 00 00 00 00 8b 44 24 04 eb
0a               
console shuts up
...
Comment 1 Bill Nottingham 2001-02-17 22:18:36 EST
Congratulations, your bios doesn't like the kernel.
Comment 2 Arjan van de Ven 2001-02-19 07:26:48 EST
Try "apm=realmode" on the lilo "append" line, or on the lilo commandline
Comment 3 Ben Levenson 2001-02-20 16:54:47 EST
"linux apm=realmode" seemed to work OK.
FWIW, I wasn't able to reproduce the oops
when I booted with linux-up.
Comment 4 Arjan van de Ven 2001-02-21 03:31:21 EST
Were you using the apm=power-off option ?
Comment 5 Glen Foster 2001-02-21 10:08:57 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 6 Ben Levenson 2001-02-21 19:58:14 EST
no. the system is running with a default lilo.conf file.
I just tried passing the apm=power-off option, and
I didn't get an oops.
Here are all of my results:
linux-up --> no problems
linux apm=realmode --> no problems
linux apm=power-off --> no problems
linux --> oops
I just realized that some of the Call Trace was not included
in my original posting.  Let me know if you need me to
attach another copy.
Comment 7 Arjan van de Ven 2001-02-22 03:53:05 EST
No need for the call-trace, it's the bios that faults. You seem to be the
(un)lucky owner of a machine with a crappy bios. We can revert back to 
beta3 behavior, but that breaks for a hole lot of other people. The basic
dilemma was

<it doesn't work for a lot of people> vs <it oopses for a few, but we can give
                                          them the commandline option>

Now, it woud be nice if we could make this PCI id dependend, so please post 
lspci and lspci -n here. (and also the brand of the motherboard + bios version
is possible, as well as the dmesg output so we might be able to trigger on that)
Comment 8 Ben Levenson 2001-02-22 12:10:05 EST
The original oops was from a Dell PowerEdge 6300 server with 4 xeon cpus.
BIOS: Phoenix ROM BIOS PLUS 1.10 A06.
(Haven't determined the motherboard information yet.)

The problem is also reproducible on an Acer Altos with 2 cpus.
 BIOS: ((I assume Acer...any other brandname wasn't obvious) v3.0 (R01-C4 01 EN)
I know this is kind of cryptic, but the information is straight from the BIOS
product information screen) 
MOTHERBOARD: Acer M19A

The lspci and dmesg information will be attached below.
Comment 9 Ben Levenson 2001-02-22 12:11:55 EST
Created attachment 10760 [details]
Dell PowerEdge lspci/lspci -n
Comment 10 Ben Levenson 2001-02-22 12:13:11 EST
Created attachment 10761 [details]
Dell PowerEdge dmesg
Comment 11 Ben Levenson 2001-02-22 12:13:57 EST
Created attachment 10762 [details]
Acer Altos lspci/lspci -n
Comment 12 Ben Levenson 2001-02-22 12:14:41 EST
Created attachment 10763 [details]
Acer Altos dmesg
Comment 13 Arjan van de Ven 2001-03-21 12:39:34 EST
SMP poweroff is not supported.
Comment 14 Ben Levenson 2001-04-05 19:34:54 EDT
closing.

Note You need to log in before you can comment on or make changes to this bug.