Bug 2820 - xterm reverse video flag is incorrectly reset by ncurses visual bell
xterm reverse video flag is incorrectly reset by ncurses visual bell
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
6.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-14 11:38 EDT by samb
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-29 11:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description samb 1999-05-14 11:38:28 EDT
When using an xterm in reverse video mode (eg. -rv switch),
and an application that uses terminfo and ncurses to control
the screen (eg. 'screen' with vbell mode on), a visual-bell
will cause the xterm to lose its reverse video state.
The reason for this is that the terminfo file included with
the ncurses package (ncurses-4.2-18,
/usr/share/terminfo/x/xterm) defines a capability sequence
for flash (used by ncurses call 'flash()', to display a
visual bell) that is incorrect; the sequence given is in
fact 'reverse-video on, reverse-video off'. This sequence
will flash the screen, but it also forces the xterm into
reverse-video off mode, causing the bug. XTerm does not in
fact support this sequence (visual bell), although it will
perform a visual bell on receipt of an audible bell when
visual bell mode is enabled (-vb switch). This incorrect
sequence is not included in the termcap entry for xterm, and
so applications that work via this interface are not
effected.
To correct this simply decompile the terminfo file for xterm
(infocmp /usr/share/terminfo/x/xterm > xterm.src), remove
the flash capability with a text editor, and recompile the
entry (tic xterm.src).
Comment 1 David Lawrence 1999-05-14 17:33:59 EDT
I have verified that this does occur in the final release of Red Hat
6.0.
Comment 2 Cristian Gafton 1999-07-28 03:35:59 EDT
assigned to pbrown
Comment 3 Preston Brown 1999-08-29 11:07:59 EDT
this has been fixed for the 6.1 ncurses.

Note You need to log in before you can comment on or make changes to this bug.