Bug 28203 - Red Hat 7.0: Unable to Start PCMCIA EtherJet: tulip_cb: RequestIO: Unsupported mode
Summary: Red Hat 7.0: Unable to Start PCMCIA EtherJet: tulip_cb: RequestIO: Unsupport...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-18 03:57 UTC by Bruce Spencer
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 17:43:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruce Spencer 2001-02-18 03:57:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win95; U)


Red Hat 7.0, kernel/kernel-pcmcia  2.2-17-14,  IBM Thinkpad 600E
Problem:  can not start EtherJet PCMCIA card. (When I run "cardctl start"
I hear a high beep followed by a low beep).  No LED light, 
no eth0.

/var/log/messages:

Feb 17 18:19:02 baspence cardmgr[2130]: executing: 'modprobe tulip_cb'
Feb 17 18:19:02 baspence kernel: tulip_cb: RequestIO: Unsupported mode
Feb 17 18:19:03 baspence cardmgr[2130]: get dev info on socket 1 failed: Resource unavailable



configuration (memory, IRQ settings in config.opts).  

Reproducible: Always
Steps to Reproduce:
1.  Startup
2.  
3.
	

Actual Results:  No LED light
No eth0 interface

Expected Results:  eth0 interface when I run ifconfig or netstat -i

Script started on Sat Feb 17 18:19:58 2001

# cardctl ident 1
Socket 0:
  no product info available
Socket 1:
  product info: "IBM", "EtherJet PC Card", "Version U11",
  "Card Assy Part Number - 85H4801"
  manfid: 0x00a4, 0x003f         # comment I changed /etc/pcmcia/config for Etherjet from 0x0113 to 0x003f to match cardctl output
                                             # Is this card version supported?
  function: 6 (network)

# cardctl status
Socket 0:
  no card
Socket 1:
  5V 16-bit PC Card
  function 0: [ready]

# tail -25 /var/log/messages
kernel: Linux PCMCIA Card Services 3.1.20
kernel:   kernel build: 2.2.17-14 #1 Mon Feb 5 14:57:25 EST 2001  # Updated to this kernel to see if it would help...no change
kernel:   options:  [pci] [cardbus] [apm]
kernel: PCI routing table version 1.0 at 0xf9e20
kernel: Intel PCIC probe:
kernel:   TI 1251A rev 00 PCI-to-CardBus at slot 00:02, mem 0x50102000
kernel:     host opts [0]: [ring] [isa irq] [pci irq 11] [lat 168/176] [bus 2/4]
kernel:     host opts [1]: [ring] [isa irq] [pci irq 11] [lat 168/176] [bus 5/7]
kernel:     ISA irqs (scanned) = 3,4,7,9,10 PCI status changes
cardmgr[2130]: starting, version is 3.1.20
cardmgr[2130]: watching 2 sockets
kernel: cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
kernel: cs: IO port probe 0x0800-0x08ff: clean.
kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x130-0x137 0x220-0x22f 0x388
kernel: cs: IO port probe 0x0a00-0x0aff: clean.
cardmgr[2130]: initializing socket 1
kernel: cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff
kernel: cs: memory probe 0x60000000-0x60ffffff: clean.
cardmgr[2130]: socket 1: IBM 10/100 EtherJet CardBus
cardmgr[2130]: executing: 'modprobe cb_enabler'
 **** here's the problem *****
cardmgr[2130]: executing: 'modprobe tulip_cb'
kernel: tulip_cb: RequestIO: Unsupported mode
cardmgr[2130]: get dev info on socket 1 failed: Resource temporarily unavailable

Comment 1 Michael K. Johnson 2001-02-21 15:50:34 UTC
Is this a regression from the 2.2.16 kernel shipped with 7.0?

Comment 2 Glen Foster 2001-08-01 17:43:22 UTC
Closing at customer's request.

Comment 3 prago 2001-08-01 18:02:13 UTC
Resolved with newer etherjet card.


Note You need to log in before you can comment on or make changes to this bug.