Bug 282051 - [RHEL4] nscd: 6657 no more memory for database 'passwd'
[RHEL4] nscd: 6657 no more memory for database 'passwd'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.2
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 04:57 EDT by Benedikt Schaefer
Modified: 2008-08-08 17:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 17:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benedikt Schaefer 2007-09-07 04:57:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):
OS: RHEL4U2
kernel: 2.6.9-55.02.ELsmp
nscd: 2.3.4-2.13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
-> cat messages |grep nscd 
Sep  2 20:40:31 mdoccn18 nscd: 6657 no more memory for database 'passwd' 
Sep  3 20:40:32 mdoccn18 nscd: 6657 no more memory for database 'passwd' 
Sep  4 20:40:33 mdoccn18 nscd: 6657 no more memory for database 'passwd' 
Sep  5 20:40:23 mdoccn18 nscd: 6657 no more memory for database 'passwd' 
Sep  6 20:40:24 mdoccn18 nscd: 6657 no more memory for database 'passwd' 

Expected results:


Additional info:
-> nscd -g 
nscd configuration: 

              0  server debug level 
 15d  0h 31m  4s  server runtime 
             -1  current number of threads 
             32  maximum number of threads 
              0  number of times clients had to wait 
             no  paranoia mode enabled 
           3600  restart internal 

passwd cache: 

            yes  cache is enabled 
            yes  cache is persistent 
            yes  cache is shared 
            211  suggested size 
         216064  total data pool size 
           2304  used data pool size 
            600  seconds time to live for positive entries 
             20  seconds time to live for negative entries 
           1301  cache hits on positive entries 
              0  cache hits on negative entries 
          97528  cache misses on positive entries 
             79  cache misses on negative entries 
              1% cache hit rate 
             24  current number of cached values 
           1913  maximum number of cached values 
             17  maximum chain length searched 
              0  number of delays on rdlock 
              0  number of delays on wrlock 
              0  memory allocations failed 
            yes  check /etc/passwd for changes
Comment 1 Kai Engert (:kaie) 2007-09-11 12:23:55 EDT
Changing bug component to glibc. This bug is about nscd, but there is no nscd
component in bugzilla. It appears nscd is being built from the glibc source rpm.#
Comment 2 Jakub Jelinek 2007-09-11 12:35:13 EDT
RHEL4.2 is very old, there have been about 18 important nscd bugfixes since then
in RHEL4 updates, several of them dealt with nscd database growing.
Please retry with RHEL4.5 or RHEL4.6 beta nscd (2.3.4-2.36 or 2.3.4-2.38).
Comment 3 Ulrich Drepper 2008-08-08 17:55:45 EDT
No reaction in almost a year.  Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.