Bug 28206 - Xfree86 hangs with neomagic
Xfree86 hangs with neomagic
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-18 00:03 EST by sethbc1980
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-18 00:03:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sethbc1980 2001-02-18 00:03:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


I have a gateway 2500 laptop, i have edited all of the config scripts and 
they are all correct.  I used Xconfigurator to set it up, and checked 
against old XF86Config's that i have.  when i do a 'startx' command, it 
simply hangs at a blank black screen.  to solve i have changed back to 
XF86_SVGA, (3.3.6)  now, i have used XFree86 4.0.1 before, and 4.0 worked 
fine as well, 4.0.2 just doesn't work.

Reproducible: Always
Steps to Reproduce:
1.Xconfigurator for a laptop with a neomagic
2.type 'startx'

Actual Results:  XFree86 locks up

Expected Results:  XFree86 probably should start up right

(the reason i label it a high priority is that after install the computer 
simply hangs when it tries to load X, this would be a problem if i didn't 
have old config files laying around and have XF86_SVGA installed)
Comment 1 Mike A. Harris 2001-02-18 00:37:03 EST
I've changed the default X configuration to use 3.3.6 by default instead
of XFree 4 since a number of people are reporting this.  Preston, changes
are checked into CVS for "Cards" file.  Next release of X & Xconfigurator
should default to 3.3.6.

Neomagic doesn't make graphics hardware anymore and they don't release their
specs either.  Thus, support for this chip is likely to stay broken unless
someone can talk Neomagic into releasing specs, or someone who has one of
these chipsets can hack code into 4 from the 3.3.x source.

Note You need to log in before you can comment on or make changes to this bug.