Bug 282281 - Blam fails to properly recover from hibernate
Blam fails to properly recover from hibernate
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
7
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 08:57 EDT by Michael De La Rue
Modified: 2008-06-16 22:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael De La Rue 2007-09-07 08:57:07 EDT
Description of problem:
I hibernated my desktop.  After restore from hibernate, one day later, blam
fails to fully update it's windows.  However it is still responsive to some
clicks in the window and sometimes updates the list of items in a feed.  

Version-Release number of selected component (if applicable):
blam-1.8.3-5.fc7

How reproducible:
two times so far.  This doesn't happen for a short hibernate.  

Steps to Reproduce:
1. start blam
2. hibernate PC (system->shutdown->hibernate)
3. wait a day
4. restart PC with power
  
Actual results:
The blam window is blank except for the gray regions which divide the three
different panes and even those are just plane.  Clicking on a feed (by guessing
where it is) sometimes brings up a list of stories.  Refresh buttons etc. are
not visible.  The stories headlines, when visible, can lead to display of the
stories, but it seems like the feeds do not refresh.  

Expected results:
Blam window continues to operate as normal.

Additional info:
I get a message about HAL failing to recover from hibernate, but I think this
isn't relevant.  Certainly other applications such as firefox work fine.  

I have no clue about mono debugging.  I tried the mono debugger but I get the
following info

Unhandled Exception: System.TypeInitializationException: An exception was thrown
by the type initializer for Mono.Debugger.Frontend.CommandLineInterpreter --->
System.DllNotFoundException: monodebuggerserver
  at (wrapper managed-to-native)
Mono.Debugger.Frontend.CommandLineInterpreter:mono_debugger_server_static_init ()
  at Mono.Debugger.Frontend.CommandLineInterpreter..cctor () [0x00000] --- End
of inner exception stack trace ---
Comment 1 Peter Gordon 2007-09-08 15:08:39 EDT
When you say "short hibernate," about how long does it take for this to occur? A
few hours? A full day? Thanks.
Comment 2 Peter Gordon 2007-09-29 15:14:17 EDT
Michael, does this still occur for you with the latest Blam in the repositories
(1.8.3-6.fc7)? 

Also, about how long do I need to hibernate to reproduce the error? 

Thanks.
Comment 3 Michael De La Rue 2007-09-30 01:14:30 EDT
It's hard to say.  I previously had the problem reliably when hibernating from
day to day (e.g. quite a bit more than 12 hours).  I've seen it happen with a
shorter hibernate, but if I hibernate less than 2 hours it doesn't normally seem
to happen.  I just tried overnight and didn't trigger the bug. I'm now not
totally sure about the cause, whether it's having it running for a long time or
hibernation.

I'll keep blam running all the time and wait until I trigger it again.  
Comment 4 Bug Zapper 2008-05-14 10:16:46 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2008-06-16 22:21:12 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.