Bug 282381 - up2date install of jta failing on RHEL4 ES 32 bit
up2date install of jta failing on RHEL4 ES 32 bit
Status: CLOSED NOTABUG
Product: Red Hat Application Server
Classification: Retired
Component: jta (Show other bugs)
2.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 09:44 EDT by Angus Thomas
Modified: 2007-09-19 12:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 12:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angus Thomas 2007-09-07 09:44:48 EDT
Description of problem:

On a fully updated RHEL4 ES system, attmpting to install
jta-1.0.1-0.b.3jpp_2rh.noarch.rpm via up2date fails.

Version-Release number of selected component (if applicable):
jta-1.0.1-0.b.3jpp_2rh.noarch.rpm

How reproducible:
Very.

Steps to Reproduce:
1. Install an up to date RHEL4 ES 32 bit machine, which doesn't have jta on it.
2. Run "up2date jta"
3.
  
Actual results:

[root@uktotemprodwww001 ~]# up2date jta

Fetching Obsoletes list for channel: prod-rhel-i386-es-4...

Fetching Obsoletes list for channel: prod-rhn-tools-rhel-4-es-i386...

Fetching Obsoletes list for channel: prod-rhel-i386-es-4-extras...

Fetching Obsoletes list for channel: prod-rhel-i386-es-4-markit...

Fetching Obsoletes list for channel: prod-rhel-4-es-i386-rhaps-2...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
jta                                     1.0.1          0.b.3jpp_2rh      noarch


Testing package set / solving RPM inter-dependencies...
########################################
There was a fatal RPM error. The message was:
Failed running rpm transaction

[root@uktotemprodwww001 ~]# tail /var/log/up2date
[Fri Sep  7 14:35:50 2007] up2date updating login info
[Fri Sep  7 14:35:50 2007] up2date logging into up2date server
[Fri Sep  7 14:35:50 2007] up2date successfully retrieved authentication token
from up2date server
[Fri Sep  7 14:35:50 2007] up2date availablePackageList from network
[Fri Sep  7 14:35:51 2007] up2date allAvailablePackageList from network
[Fri Sep  7 14:35:53 2007] up2date installing packages: []
[Fri Sep  7 14:35:53 2007] up2date Failed running rpm transaction - %pre %pro
failure ?.



Expected results:
Installation of jta

Additional info:
There are no other problems with using up2date for any other pacakges.
Downloading the jta RPM and installing it with "rpm -i" succeeds.

up2date version is the latest. (up2date-4.5.5-7.el4)
Comment 1 Angus Thomas 2007-09-07 11:50:43 EDT
I've reproduced this on a fully updated RHEL4 ES machine against rhn.redhat.com,
rather than against our satellite:

[root@uklnx001 ~]# up2date jta

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching Obsoletes list for channel: rhel-4-es-i386-rhaps-2...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
jta                                     1.0.1          0.b.3jpp_2rh      noarch


Testing package set / solving RPM inter-dependencies...
########################################
There was a fatal RPM error. The message was:
Failed running rpm transaction
[root@uklnx001 ~]# tail /var/log/up2date
[Fri Sep  7 16:48:09 2007] up2date successfully retrieved authentication token
from up2date server
[Fri Sep  7 16:48:09 2007] up2date availablePackageList from network
[Fri Sep  7 16:48:12 2007] up2date allAvailablePackageList from network
[Fri Sep  7 16:48:42 2007] up2date updating login info
[Fri Sep  7 16:48:42 2007] up2date logging into up2date server
[Fri Sep  7 16:48:43 2007] up2date successfully retrieved authentication token
from up2date server
[Fri Sep  7 16:48:43 2007] up2date availablePackageList from network
[Fri Sep  7 16:48:46 2007] up2date allAvailablePackageList from network
[Fri Sep  7 16:48:50 2007] up2date installing packages: []
[Fri Sep  7 16:48:50 2007] up2date Failed running rpm transaction - %pre %pro
failure ?.
[root@uklnx001 ~]#
Comment 3 Fernando Nasser 2007-09-19 12:11:12 EDT
geronimo-jta-1.0.1B-api-1.0-3jpp_1rh.noarch.rpm  is what provides JTA now, not
the jta package, which is Obsoleted.  So when trying to install it using up2date
it fails as the up2date depsolver is aware that jta has been Obsoleted. 
Installing it with a plain rpm succeeds because a depsolver is not being used so
Obsoletes is not being checked *unless* geronimo-jta-1.0.1B-api is already
instaled (and in that case jta should not be installed by rpm either).
Comment 4 Fernando Nasser 2007-09-19 12:12:04 EDT
jta is an "Obsoleted" package, please use geronimo-jta-1.0.1B-api from now on

Note You need to log in before you can comment on or make changes to this bug.