Bug 28265 - (xset) broken - doesn't allow +fp properly
(xset) broken - doesn't allow +fp properly
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 25325 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 00:12 EST by Michal Jaegermann
Modified: 2007-03-26 23:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 12:54:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-02-19 00:12:42 EST
Here are notest from test of XFree86-4.0.2-7 from rawhide.  on Alpha
UP1100 machine equipped with G450 Matrox video card.  This setup at
least works, as opposed to XFree86-4.0.1 and earlier, thanks to patches
from David Woodhouse <dwmw2@infradead.org> incorporated in this release,
but the whole thing is awfully touchy.  This means that on the slightest
provocation one gets a total lockup of a machine - no keyboard, no
network, no sysrq key which is supported by kernels in use and turned
on.  The only way out it to reset and/or power down.  I do not have
also any traces in log files.

My XF86Config-4 file, which I constructed with a big effort and troubles
Thursday, and which worked, stopped working Friday for mysterious
reasons.  After further experiments it turned out that with the
following "Modes", where all corresponding modelines were defined
explicitely or modes will be not found

  Modes "1024x768" "1280x960" "1280x1024" "1600x1200" "800x600" "1856x1392"

then things work ok.  If I will put as the first mode on this line one
of these "1280x960", "1280x1024" or "1600x1200" then is a power switch
time.  If one of remaining three starts this line then X does works
and all defined modes are available.  Here is a fragment of a log file
describing used modes in greater detail:

(==) MGA(0): Min pixel clock is 12 MHz
(==) MGA(0): Max pixel clock is 360 MHz
(II) MGA(0): Monitor0: Using hsync range of 30.00-86.10 kHz
(II) MGA(0): Monitor0: Using vrefresh range of 50.00-160.00 Hz
(II) MGA(0): Clock range:  12.00 to 360.00 MHz
(WW) MGA(0): Default mode "1792x1344" deleted (hsync out of range)
(WW) MGA(0): Default mode "1920x1440" deleted (hsync out of range)
(WW) MGA(0): Default mode "1920x1440" deleted (hsync out of range)
(--) MGA(0): Has SDRAM
(--) MGA(0): Virtual size is 1856x1392 (pitch 1856)
(**) MGA(0): Mode "1024x768": 75.0 MHz, 56.5 kHz, 71.1 Hz
(**) MGA(0): Mode "1280x960": 148.5 MHz, 85.9 kHz, 85.0 Hz
(**) MGA(0): Mode "1280x1024": 135.0 MHz, 81.7 kHz, 77.1 Hz
(**) MGA(0): Mode "1600x1200": 162.0 MHz, 79.4 kHz, 64.6 Hz
(**) MGA(0): Mode "800x600": 60.8 MHz, 55.8 kHz, 85.0 Hz
(**) MGA(0): Mode "1856x1392": 218.3 MHz, 86.4 kHz, 60.0 Hz


Wihout specifying any modes to use, only monitor frequency limits, a
server on its own comes in "1856x1392@60 Hz" mode, which means tiny
pictures and a huge flicker, and that is it.  Morevoer it is enough to
put a "wrong" value as an upper limit of "HorizSync" 79.0, 82.0 or 64.3
(standard VGA frequencies) instead of a correct for my monitor 86.0 to
cause an instant lockup.  When trying lower VGA frequencies from 57 down
to 31.5 I got also few more working interlaced modes, which were not
very interesting on this hardware, but no crashes.

None of configuration tools really works.  Xconfigurator is causing a
lockup on any attempt to test anything. 'xf86cfg' presents as the only
option "640x480@60 Hz" and whatever I am doing I am not able to change
its mind.  One can try any menu whatsoever and nothing changes.  'man
xf86cfg' does not tells very much, I am afraid, and filling fields in
"Expert mode" (monitor parameters, say) also does not seem to have any
discernible effect.

When starting a server I am getting always, regardless if I am running
xft or I just simply listed all font path elemens in a configuration
file:

Could not init font path element /usr/X11R6/lib/X11/fonts/Type1,
removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo,
removing from list!
Could not init font path element /usr/share/fonts/default/Type1,
removing from list!
Could not init font path element /usr/share/fonts/ISO8859-2/Type1,
removing from list!
Could not init font path element /usr/share/fonts/ISO8859-7/Type1,
removing from list!

Is support for Type1 and Speedo fonts not compiled in this server?
All directories listed above actually do exist and are not emtpy.
The fact that in a font picker for gnome-terminal setting a filter
to "Scalable" fonts only ends up with empty font lists confirms that
this at least does not work.  Trying to use 'xset' to add such
directories to a font path results in:

$ xset +fp /usr/share/fonts/default/Type1/  
X Error of failed request:  86
  Major opcode of failed request:  51 (X_SetFontPath)
  Serial number of failed request:  9
  Current serial number in output stream:  11

Exactly the same error is reported when one tries to add a directory
with TrueType fonts.

The other funny thing I run into.  Because I was locking up regularly
with no way to unmount file systems (sysrq does not work as well when my
Matrox goes south) then I had mounted read only everything I could get
away with.  This read-only property I tracked eventually as a reason for
these messages when I tried to restart from a non-root account:

Gnome-ERROR **: Could not set mode 0700 on private per-user Gnome
directory </home/michal/.gnome_private> - aborting

while mode on /home/michal/.gnome_private is actually already 0700 and
it is owned by michal.  Gnome (gnome-core-1.2.1-34) still attempts
to reset that mode, I guess just in case, even when there is no
real need for that.

  Michal
  michal@harddata.com
Comment 1 Bill Nottingham 2001-02-19 00:38:28 EST
xset +fp has been broken ever since XFree-4.0.
Comment 2 Michal Jaegermann 2001-02-23 21:59:55 EST
I only now realized that all these "Could not init font path element" 
errors I reported stem from that that 4.0.2 server in question does
not load "type1", or "freetype", or "speedo" modules unless explicitely
asked to.  Once corresponding requests are added in Modules section
of a cofiguration file then errors disappear and fonts in question
do show up.

This is a bit surprising change of a behaviour in conparison with
earlier versions of X and files produced by configuration tools do not
have these "load" statements.

Also AbiWord when it cannot find its fonts behaves in the most
obnoxious manner (SIGSEGV and the like).
Comment 3 Mike A. Harris 2001-03-07 08:21:02 EST
Are you running xfs at boot time?  Make sure xfs is running.
Comment 4 Michal Jaegermann 2001-03-07 11:20:55 EST
Yes, I do run xfs at a boot time, or I specify FontPath in my configuration
file.  This does not matter.  But see my comments from 2001-02-23.  I run
into the same problem with fonts also on x86 with 4.0.2 and the solution
is the same.  One has to ask for modules like "type1" or "freetype" explicitely
in a configuration file; otherwise they are not loaded.
Comment 5 Mike A. Harris 2001-03-18 15:22:27 EST
Ok, I think I grok what you're saying now.  I just reproduced exactly what
you are claiming on x86, so it is not specific to alpha.  I'll see
if we can have Xconfigurator do this automatically, as it is brain damaged
the way it is now IMHO.

Thanks very much for reporting this stuff Michal, and keeping up with
new info, etc.  It helps us out a lot!  I'm going to see if we can solve
this now in a useful way.  Thanks again.
Comment 6 Mike A. Harris 2001-03-23 01:03:31 EST
I've researched this a bit and here is what it appears you need to do.
If you are using xfs, things should work fine (XFree86 4.0.3), if you
are not using xfs then you need to configure your XF86Config to properly
load the modules.  You shouldn't need the modules if you are using xfs
which is our default behaviour.

xset thus doesn't contain a bug WRT the problem you're having.  The problem
is related to configuration/default configuration issues.  I don't see it as
a bug anymore however we will put some commented out lines in the default
config files to ease configuration.

If you're not satisfied with this solution, please open a new bug report
against Xconfigurator, as ultimately that is what creates the configs.


Comment 7 Michal Jaegermann 2001-03-23 04:57:49 EST
For obvious reasons the report could not be about XFree86 4.0.3; but
a configuration file on machine in question always had

Section "Files"
        FontPath "unix/:7100"
EndSection

Comment 8 Mike A. Harris 2002-01-25 02:09:31 EST
*** Bug 25325 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.