Bug 28269 - printconf cannot set local printer. error from
printconf cannot set local printer. error from
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 01:55 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 22:17:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-19 01:55:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


system is HP6535, 128M RAM, HP Lasejet 832C. Printer works just fine with
Win98 SE and SUSE Linux 6.4.

Running 'printconf-gui as user gives following error:-
[d3j452@winston d3j452]$ printconf-gui
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
Traceback (innermost last):
  File "/usr/sbin/printconf-gui", line 2, in ?
    import gtk
  File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
    _gtk.gtk_init()
RuntimeError: cannot open display

Running  'printconf-gui' as 'root' gives following error:-

[root@winston d3j452]# printconf-gui

** CRITICAL **: file alchemist.c: line 3226 (AdmList_addChild): assertion
`_adm_valid_name(name)' failed.
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/printconf-gui", line 863, in handle_new_button
    queue = new_queue(name)
  File "/usr/sbin/printconf-gui", line 125, in new_queue
    queue = dynamic_ctx.getDataByPath('/' + namespace +
'/print_queues').addChild(Alchemist.Data.ADM_TYPE_LIST, name)
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 134, in
addChild
    name))
Alchemist.ListError: addChild failed


Printtool does NOT autodetect printer. Trying to generate print queue by
selecting HP 832C does not create print queue. /etc/printcap is empty.

Have re-installed "Fisher" twice, taking default partitioning, KDE
workstation. Never asks if I wish to setup printer!! (I seem to remember we
did in 6.2 ?!).

Reproducible: Always
Steps to Reproduce:
1. "printtool"
2. Try to create '832C' as queue name
3. Select HP ==> Deskjet 832C
4. Click OK
5. NO QUEUE generated!!!
	

Actual Results:  Error output in description	

Expected Results:  I should have been able to create a printer.

Correct driver is apparenetly selected...
Comment 1 Glen Foster 2001-02-21 10:06:50 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Crutcher Dunnavant 2001-02-21 22:17:18 EST
did you click 'apply'?

(Yes, it should bug you about saving and restarting, but it does now.)
Comment 3 Crutcher Dunnavant 2001-03-06 11:33:30 EST
Ah, this is because names (for various reasons) cannot start with a didgit in
printconf. This is a limitation of the encoding, and a check to prevent this
error has been introduced.

So, the traceback won't happen, but I can't make '832c' a valid name and keep
the configuration merging capabilities of printconf.

Note You need to log in before you can comment on or make changes to this bug.