Bug 28272 - ping to gateway fails
ping to gateway fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 03:12 EST by Pat Grimm
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Grimm 2001-02-19 03:12:40 EST
Problem: Cannont ping gateway with SDSL under RedHat Linux 7.0.

I have an SDSL connection on a dual boot Win2k/RedHat 7.0 system (fresh 
Linux install kernel 2.2.16).  My computer has dual 3Com 3C509B NICs.  One 
configured for DSL access, one for my internal LAN.  The DSL connection 
has a fixed IP address assigned by my ISP.  The SDSL modem is a 
CopperRocket 201 (also sold by 3Com as a 3Com IDSL modem, now 
discontinued).

I manually configured the dual NICs to disable Plug-n-Play and set the 
base address and IRQ. I can ping both NICs with no problem, but not the 
gateway.  When I try to ping the gateway the data light blinks on the 
CopperRocket but there is no response.

At this point I have read every network/routing source I can find on the 
internet but have no solution for this problem.  A call to my ISP is 
pretty much futile.  I have been told that this is a straight ethernet 
connection.  This SDSL connection does not use PPPoE so rp-pppoe is not 
needed. One ISP tech suggested using Kppp to set up my SDSL as a modem.  
There is no device type to match the CopperRocket and a "Query Modem" only 
produced packet errors at the device.

If you look at the output below you will see 2 default routes for the 
gateway.  This was discussed in another bug report for the ifup script. I 
tried removing the GW info from ifcfg-eth0 and manually set routes with 
either metric of 1 or 0 with no success.  I have also tried this with a 
single NIC with no success. I have also run TCPDUMP and received something 
like ARP who-has gw.address. I did not really know how to interpret this 
but it looked like it could not find out what owned the GW. In addition I 
have tested with packet_forwarding on/off.

I hope that this is not really a bug because I was looking forward to 
using RedHat but without a connection to the internet it makes things very 
difficult.

PatG

---------------------------------------------------------------------------
-
Command line output:

# route -n
Kernel IP routing table
Destination     Gateway      Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0      255.255.255.0   U     0      0        0 eth1
x.x.x.0         0.0.0.0      255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0      255.0.0.0       U     0      0        0 lo
0.0.0.0         x.x.x.1      0.0.0.0         UG    0      0        0 eth0
0.0.0.0         x.x.x.1      0.0.0.0         UG    1      0        0 eth0

(note above that there are two routing entries for eth0 to the gateway. 
One with a metric of "0" and one with a "1".  I have made no manual 
routing changes under this configuration. ifup script prob.)

# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:A0:24:24:34:66  
          inet addr:x.x.x.36  Bcast:x.x.x.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:7 Base address:0x2d0 

eth1      Link encap:Ethernet  HWaddr 00:A0:24:74:64:13  
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:10 Base address:0x2e0 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
Comment 1 Pat Grimm 2001-02-20 23:28:27 EST
Ok, I did some more testing.

After thouroughly reading the Networking HOWTO my 3c509b I configured as follows

3c509b----
PnP disabled
IRQ 7, IO 0x2d0
Tranceiver set to RJ45

PC BIOS----
PnP OS disabled

I obtained a DSL router - Hawking PN9225 and set it up with my "other OS" to be 
a DHCP server. Verified operation with DHPC (I am connected with it now).

Setup
SDSL Modem--DSL router--Linksys Hub--NIC

In RedHat
booted to run level 3
did a ifdown eth0 and ifdown eth1
deleted /etc/.../ifcfg-eth0
deleted /etc/.../ifcfg-eth1
removed alias info from /etc/modules.conf
removed gateway and DNS info from NETWORKS
shutdown
removed eth1 NIC
reboot to run level 3
started x
ran linuxconf
   set adapter eth0 
     driver 3c509
     irq 7
     set to DHCP
Upon activating changes
DHCP failed

rebooted to run level 3
eth0 detected IRQ 7, IO 0x2d0
start eth0 failed
lights on Linksys hub show activity on both NIC and DSL router port during eth0 
DHCP request

tried - # pump eth0 -  still failed
ran   - # cat /proc/net/dev
no errors reported for lo or eth0

I am at a loss on what to try next and have spent way too much time on this.
If you could please look this over and provide some diagnostics I would be 
happy to help. Being new to Linux everything I try requires a steep learning 
curve.

To me, this really looks like a driver issue, or some underlying confilt that 
is beyond my diagnostic skill.

Here is the rest of my HW config for the record

Abit VT6X4 MB
http://www.abit-usa.com/english/product/motherboards/vt6x4.htm
On board Via Audio driver lot loaded in RH7 (causes system freeze)
Intel PIII 800E
100 MHz bus
256 MB Ram
Elsa GeForce 256 AGP (4x AGP)
Adaptec 2940 PCI SCSI Card

Please email any correspondence

Thank you,

Pat
Comment 2 Pekka Savola 2001-02-22 17:40:31 EST
To get rid of the duplicate default gateway, move your GATEWAY= definition from ifcfg-ethX to /etc/sysconfig/network.
The description of the bug is at: http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=19641

Try pinging with 'ping -n'.  Do you still see problems?

Comment 3 Pat Grimm 2001-02-23 18:12:38 EST
I looked through my hardware pile and came up with a 3Com 3C905-TX PCI card.
After installing it and setting it up everything is working fine.  I entered the
exact same net config info that I tried with the other card.

My conclusion: One of the following problems exists.

1. There is a error in the 3C509B driver
...OR...
2. There is some odd compatability issue with the 3C509B and my other hardware
under Linux.

If RedHat would like me to do more testing (be reasonable) I will be glad to
help.  I have previously posted all of my hardware info.

Thank You,

PatG
Comment 4 Pat Grimm 2001-03-05 20:24:03 EST
Report on more testing:

I scaped together more hardware.

Intel Pentium 233 MMX on Matsonic MB
32 MB Ram
S3 Virge/DX Video w/4MB
Seagate 1.6 GB HD
3C509B NIC
(wow, this system is a screamer!!!)

Long story short. I installed TurboLinux 6.0 workstation (sorry) (Kernel 2.2.15)
with just the basics, no X or other fancy stuff. After the install I configured
the network just like I did before on the other computer. Everything worked
great and I was able to get the NIC to ping to multiple places on the internet.

So, based on my testing I say that there IS some obscure issue with my more
recent hardware and the 3C509 driver. Is anyone interested?

Pat
Comment 5 Pekka Savola 2001-07-22 15:40:17 EDT
This might be already be fixed (if it is a driver issue) in newer releases, but all in all, this appears to be
more of a kernel issue.  Changing component.
Comment 6 Alan Cox 2003-06-09 11:03:50 EDT
Description fits an IRQ being used by PCI not set in BIOS for the ISA IRQ of the
3c509B.

Old bug, not enough info to be worth keeping open so closing. Needless to say
people experiencing similar bugs should still file a new bug about it

Note You need to log in before you can comment on or make changes to this bug.