Bug 28285 - Update failed due to invalid configuration
Update failed due to invalid configuration
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 07:56 EST by jbj
Modified: 2015-01-07 18:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jbj 2001-02-19 07:56:57 EST
With existing Redhat Network setup on Redhat 7.0 machine after upgrading to
fisher I tried
to use up2date to test the functionality. The program aborted with an error
about an invalid 
configuration. I removed the configuration and allowed the new version (the
one with fisher I presume) to create a new entry it's self and the program
functioned correctly.
Comment 1 Adrian Likins 2001-02-19 13:24:56 EST
This is expected behaviour. The beta releases point to a different
set of up2date servers than the standard release, and the servers that
7.0 points at do not support up2date services for the beta. 

The beta version of up2date only supports anonymous registration,
and includes none of the RHN web functionality. 

Sounds like you had registered with the main servers, then tried
to use your certificate you got from there with the beta servers,
which doesnt work.
Comment 2 jbj 2001-02-19 15:54:46 EST
This was very minor for me but for someone new to Linux or computers in general
this could be quite a problem. Several people around this area if they encounter
this will end up calling me to ask
how to fix the ('CRASH'  as they usually put it often without enough information
to find the bug).

Would it be possible for the upgrade program to simply remove the
/etc/sysconfig/rhn/systemid file?
Comment 3 Adrian Likins 2001-02-19 16:24:05 EST
It doesnt need to for real releases, but the beta is different. 
The same server and system_id will work for the "live" servers
and all the versions supported on it.

This is only an issue on beta releases, which are of course,
unsupported. I'll see what it would take for the servers to
return a more informative error message that will point this out.
Comment 4 Cristian Gafton 2001-02-19 20:32:47 EST
Assigned QA to jturner
Comment 5 Preston Brown 2001-02-20 12:33:11 EST
this will never happen except in the beta case.  If you are using the beta, you
are expected to have to be a little smarter than the average new user.

Note You need to log in before you can comment on or make changes to this bug.