Bug 282851 - hwcert doesn't support 10GigE cards
hwcert doesn't support 10GigE cards
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
high Severity medium
: ---
: ---
Assigned To: David Zeuthen
Red Hat Hardware Certification
:
Depends On:
Blocks: 253733
  Show dependency treegraph
 
Reported: 2007-09-07 13:53 EDT by George Beshers
Modified: 2013-03-05 22:51 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 12:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hal.out (111.00 KB, application/x-mimearchive)
2007-09-07 17:21 EDT, George Beshers
no flags Details
plan.xml (2.00 KB, application/x-mimearchive)
2007-09-07 20:09 EDT, George Beshers
no flags Details

  None (edit)
Description George Beshers 2007-09-07 13:53:59 EDT
Description of problem:

The kernel seems to support

In lspci, it showed 03:00.0 Ethernet controller: MYRICOM Inc. Myri-10G
Dual-Protocol NIC (10G-PCIE-8A).

  But hts used was 5.0-48, the version in 
ftp://partners.redhat.com/a166eabc5cf5df158922f9b06e5e7b21/hwcert/

does not seem to recognize it.

I suspect this is just an oversight in some table.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
IT#131679
http://bugworks.engr.sgi.com/query.cgi/962321
Comment 1 Rob Landry 2007-09-07 14:49:48 EDT
Correcting the product.  Please use "Red Hat Hardware Test Suite" as the product
to report hts bugs in the future.

Can we get a copy of the output from 'hal-device', also if handy a copy of the
plan.xml generated from R48.
Comment 2 George Beshers 2007-09-07 17:21:21 EDT
Created attachment 190531 [details]
hal.out
Comment 3 George Beshers 2007-09-07 20:09:58 EDT
Created attachment 190611 [details]
plan.xml
Comment 4 Greg Nichols 2007-09-17 20:15:48 EDT
The hts plan shows tests for two interfaces: peth2 and eth1.   I take it
there's a third interface hts is not planning a test for?  If so, it's not
showing up in HAL, so this must be a RHEL bug or a driver problem.
Comment 5 George Beshers 2007-10-17 21:07:38 EDT
Greg,

Sorry I have been distracted.  In the hal.out the Myricom device is #24;
what piece of software is responsible for getting it into plan.xml?
That is, is there a library that digest the hal.out information that
is the problem?


24: udi = '/org/freedesktop/Hal/devices/pci_14c1_8'
  info.udi = '/org/freedesktop/Hal/devices/pci_14c1_8'  (string)
  linux.subsystem = 'pci'  (string)
  linux.hotplug_type = 1  (0x1)  (int)
  pci.subsys_product = 'Unknown (0x0008)'  (string)
  pci.subsys_vendor = 'MYRICOM Inc.'  (string)
  info.product = 'Myri-10G Dual-Protocol NIC (10G-PCIE-8A)'  (string)
  pci.product = 'Myri-10G Dual-Protocol NIC (10G-PCIE-8A)'  (string)
  info.vendor = 'MYRICOM Inc.'  (string)
  pci.vendor = 'MYRICOM Inc.'  (string)
  pci.device_protocol = 0  (0x0)  (int)
  pci.device_subclass = 0  (0x0)  (int)
  pci.device_class = 2  (0x2)  (int)
  pci.subsys_vendor_id = 5313  (0x14c1)  (int)
  pci.subsys_product_id = 8  (0x8)  (int)
  pci.vendor_id = 5313  (0x14c1)  (int)
  pci.product_id = 8  (0x8)  (int)
  info.linux.driver = 'myri10ge'  (string)
  pci.linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:00.0/0000:03:00.0' 
(string)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_3510'  (string)
  info.bus = 'pci'  (string)
  linux.sysfs_path_device =
'/sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:00.0/0000:03:00.0' 
(string)
  linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:00.0/0000:03:00.0' 
(string)
Comment 6 Greg Nichols 2007-10-18 10:08:48 EDT
HTS looks for any device with "net" in its info.capabilities attribute.  If this
is found, it looks at net.interface to get the logical device.  So, #24 above
does not meet the criterion.

So, the problem is that information from HAL is not sufficient for HTS to plan a
test for this device.
Comment 7 George Beshers 2008-02-06 16:19:18 EST
David,

dwa suggested that you would know what to do with this.

We have one of the cards installed in the Westford lab.

George
Comment 9 Matěj Cepl 2008-09-08 11:23:28 EDT
Shouldn't this be closed? Isn't it obsolete? If not, then is this the right Product?

Note You need to log in before you can comment on or make changes to this bug.