Bug 283051 - libtheora selinux text relocation error
libtheora selinux text relocation error
Status: CLOSED DUPLICATE of bug 253591
Product: Fedora
Classification: Fedora
Component: libtheora (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 15:49 EDT by Paul Jenner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 18:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2007-09-07 15:49:40 EDT
Description of problem:

totem fails to load theora gstreamer plugin with libtheora selinux text
relocation error.

[psj@localhost]$ totem --gst-debug-level=1
http://csclub.uwaterloo.ca/files/rms-talk.ogg

(totem:11256): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgsttheora.so': /usr/lib/libtheora.so.0: cannot
restore segment prot after reloc: Permission denied

sealert shows:

SELinux is preventing /usr/bin/totem from loading /usr/lib/libtheora.so.0.2.0
which requires text relocation.

eu-findtextrel gives:

[psj@localhost CVS]$ eu-findtextrel /usr/lib/libtheora.so.0.2.0
either the file containing the function 'theora_decode_header' or the file
containing the function 'theora_encode_header' is not compiled with -fpic/-fPIC

Version-Release number of selected component (if applicable):

[psj@localhost]$ rpm -qf /usr/lib/libtheora.so.0.2.0 
libtheora-1.0alpha8-0.1.svn13393.fc7

How reproducible:

Always

Steps to Reproduce:
1. totem --gst-debug-level=1 http://csclub.uwaterloo.ca/files/rms-talk.ogg
  
Actual results:

Fails to load plugin with error:

(totem:11256): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgsttheora.so': /usr/lib/libtheora.so.0: cannot
restore segment prot after reloc: Permission denied

and associated selinux audit error

Expected results:

Should load plugin and play

Additional info:
Comment 1 Behdad Esfahbod 2007-09-07 18:02:20 EDT

*** This bug has been marked as a duplicate of 253591 ***

Note You need to log in before you can comment on or make changes to this bug.