Bug 28316 - 1024x768 does not work on Trident Cyber9397
1024x768 does not work on Trident Cyber9397
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 11:24 EST by Mitch Fisher
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 06:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitch Fisher 2001-02-19 11:24:40 EST
When running XFree86 on the Trident Cyber9397, only the 800x600 mode works
correctly.  WHen running 1024x768 only about 1" of the righmost part of the
screen is displayed - the remainder is completely black.

This has been run from a Gateway Solo 9100 (Laptop) with a 4mg Trident PCI
adapter.  Video worked correctly with RedHat 6.2.
Comment 1 Glen Foster 2001-02-21 10:13:05 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Mike A. Harris 2001-02-25 09:20:32 EST
Attach your X server logs, and you XF86config files please.
Comment 3 Mike A. Harris 2001-03-18 23:23:17 EST
I am still awaiting your information.  You can attach the server log and
XF86Config-4 files using the link below.  Without these files and without the
hardware to test on it will be impossible to look into this any further.
Comment 4 Mitch Fisher 2001-03-22 00:53:44 EST
I no longer have the RedHat XF86Config file.  However, this problem is identical
on other distrobutions as well.  This is not a RedHat problem but an XFree86 4.x
problem.
Comment 5 Shane Dunlea 2001-05-06 12:43:03 EDT
I had the same problem with an NEC Ready 440T Laptop (with the same video 
card). The problem was overcome by forcing X to use the XF86_SVGA server by 
creating the script /etc/X11/xinit/xserverrc:

  #!/bin/sh
  exec XF86_SVGA

which is read by default when starting X. I had to setuid root on XF86_SVGA. 
The xinit man page advised against this for security reasons and said that 
Xwrapper should be used instead to avoid this. Running Xwrapper caused the same 
problem (X is a symlink to xwrapper) and I couldn't find any config files for 
Xwrapper, so this was the best solution I could find. I don't understand why 
this works: I'm pretty sure my previous setup used XF86_SVGA anyway (but 
perhaps indirectly?)
Comment 6 Mike A. Harris 2001-05-07 06:22:45 EDT
The proper way to use XFree86 3.3.6 is not to edit any scripts but
to use "Xconfigurator --preferxf3".  I would strongly recommend reinstalling
all XFree86 packages prior to doing this however if you've edited the
files.  Others have commented that 3.3.6 works for them so I am closing
this bug.  Realistically we can't fix the bug in 4.x until XFree86 fixes
it in the base release.

Note You need to log in before you can comment on or make changes to this bug.