Bug 28317 - bind requires libdns.so.4
Summary: bind requires libdns.so.4
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-19 16:42 UTC by Karsten Hopp
Modified: 2007-04-18 16:31 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-20 13:12:15 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2001-02-19 16:42:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.2.16ext3 i686)


bind requires this library, which currently is in bind-utils.
I think the library should be moved to bind. The other option
would be to add a Requires: bind-utils, but I don't think this
is the proper way.

Reproducible: Always
Steps to Reproduce:
1. Install bind, but not bind-utils
2. try to find out which package provides libdns.so.4  ;-(
3.
	

Actual Results:  libdns.so.4 is needed by  bind-9.1.1-0.2

Expected Results:  The bind package should be self containing. There is no
need to 
install bind-utils on a DNS server.

Comment 1 Bernhard Rosenkraenzer 2001-02-20 13:12:11 UTC
libdns.so.4 is also needed by host, nslookup, dig and friends.
Requiring bind for those basic tools to work is not really an option, so 
bind-utils is the right place for libdns.

Adding Requires: bind-utils to bind is the right thing to do; done in 9.1.0-3.


Note You need to log in before you can comment on or make changes to this bug.