Bug 283191 - [RHEL5]: Xen kexec very often fails to succeed on certain hardware (HPET?)
[RHEL5]: Xen kexec very often fails to succeed on certain hardware (HPET?)
Status: CLOSED DUPLICATE of bug 473038
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 16:51 EDT by Chris Lalancette
Modified: 2009-01-22 03:41 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 03:41:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full output from the hang after a kexec (3.80 KB, text/plain)
2007-09-07 16:51 EDT, Chris Lalancette
no flags Details
dmidecode from the machine that won't kexec reliably (12.99 KB, text/plain)
2007-09-07 16:52 EDT, Chris Lalancette
no flags Details

  None (edit)
Description Chris Lalancette 2007-09-07 16:51:33 EDT
Description of problem:

When using kdump on Xen kernels on certain pieces of hardware, I very often fail
the kexec.  In particular, what happens is that I "echo c >
/proc/sysrq-trigger", the kexec kernel starts to come up, and then just hangs
around forever "Using HPET for base-timer" (I'll upload the complete log). 
Sometimes it doesn't hang, but most times it actually does.

I'll also attach more information about the hardware, but it is an AMD system
with 8GB of RAM, running the 2.6.18-45.el5xen 32-bit kernel.  The grub.conf
entry is:

title Red Hat Enterprise Linux Server (2.6.18-45.el5.bz251341_chrisxen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-45.el5 com1=115200,8n1 crashkernel=128M@32M
        module /vmlinuz-2.6.18-45.el5xen ro root=/dev/VolGroup00/LogVol00
console=tty0 console=ttyS0,115200
        module /initrd-2.6.18-45.el5xen.img
Comment 1 Chris Lalancette 2007-09-07 16:51:33 EDT
Created attachment 190491 [details]
Full output from the hang after a kexec
Comment 2 Chris Lalancette 2007-09-07 16:52:09 EDT
Created attachment 190501 [details]
dmidecode from the machine that won't kexec reliably
Comment 3 Stephen Tweedie 2007-09-10 08:58:19 EDT
> with 8GB of RAM

In that case, does it help if you use the PAE kernel for the kdump?
Comment 4 Chris Lalancette 2009-01-22 03:41:14 EST
Probably another dup of 473038.  Closing it as such.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 473038 ***

Note You need to log in before you can comment on or make changes to this bug.