Bug 283281 - "xmlto pdf" crashes
"xmlto pdf" crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xmlto (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 18:27 EDT by Horst H. von Brand
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 08:22:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A simple example file showing the problem (144 bytes, text/plain)
2007-09-07 18:27 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2007-09-07 18:27:25 EDT
Description of problem:
I tried to print out an asciidoc book, and got an xmlto crash.

Version-Release number of selected component (if applicable):
xmlto-0.0.18-14

How reproducible:
Always

Steps to Reproduce:
1. asciidoc -b docbook -d book mybook.txt
2. xmlto pdf mybook.xml
3.
  
Actual results:

Lots of error messages, and finally:

  pdfTeX warning: pdfxmltex (file /var/lib/texmf/fonts/map/pdftex/updmap/pdftex.m
ap): ambiguous entry for `toti10': font file present but not included, will be 
treated as font file not present
  }]
  ! TeX capacity exceeded, sorry [save size=5000].
  \utfeight@protect@chars ...\string ##3\string ##4}
                                                  
  l.205 />
         </fo:block></fo:block></fo:flow></fo:page-sequence><fo:page-sequence...

  !  ==> Fatal error occurred, no output PDF file produced!

Expected results:
PDF file...

Additional info:
asciidoc-8.1.0-1.fc7
texlive-2007-0.12.fc8
Comment 1 Horst H. von Brand 2007-09-07 18:27:25 EDT
Created attachment 190561 [details]
A simple example file showing the problem
Comment 2 Jindrich Novy 2007-09-12 08:22:25 EDT
Please increase save_size in your /etc/texmf/web2c/texmf.cnf from 5000 to
something bigger, 10000 should suffice. It's not really a xmlto bug, but it's
caused by the default underestimated texlive configuration, will be fixed in
texlive 0.13.

Note You need to log in before you can comment on or make changes to this bug.