Bug 28340 - DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')
Summary: DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-19 20:48 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:48:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2001-02-19 20:48:35 UTC
The addition of

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')

to the default redhat.cf is a nice example of RedHat's obvious commitment i
7.1 to make more secure defaults.  I think this is an important goal.

That said, this is pretty obscure.  I have RedHat 7.1 beta running on a
test box that I'm simulating all my normal operations with so I can be
comfortable upgrading to 7.1 shortly after it comes out.  One of these
boxes is an actual mail server.  I couldn't find anything documented about
this change or how to fix it.  Luckily, I know how to write a sendmail
configuration and how to use netstat -an | grep LISTEN, so it didn't take
me too long to discover this.  I imagine some people expecting to run mail
hubs under 7.1 will probably have a hard time figuring out why sendmail
doesn't seem to be working even though it is running.

I'm not really suggesting that the default be changed, but I wonder whether
there may not be a better way to do this.  I also hope that
/usr/lib/sendmail-cf/cf/redhat.mc should be marked %config in the rpm.

It may be better to have this in /etc/mail/mail.mc rather than redhat.mc
since people who are configuring their own mail servers are more likely to
find it there.

Comment 1 Jay Berkenbilt 2001-02-19 20:53:38 UTC
My mistake -- I see it's in sendmail.mc already.  I wonder what kind of braino I
just made.  Oh -- redhat.mc is the default sendmail.mc.  Sorry.



Note You need to log in before you can comment on or make changes to this bug.