This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 28348 - PCI: No IRQ known for interrupt pin A of device 00:13.0
PCI: No IRQ known for interrupt pin A of device 00:13.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 16:46 EST by pmoors
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 17:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pmoors 2001-02-19 16:46:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i586)


Toshiba Satellite 2535CDS with ToPic97 controller.

Error messages for /etc/rc.d/init.d/pcmcia start:

Starting pcmcia: PCI: No IRQ known for interrupt pin A of device 00:13.0.
Please try using pci=biosirq.
Starting pcmcia: PCI: No IRQ known for interrupt pin B of device 00:13.1.
Please try using pci=biosirq.
Yenta IRQ list 06b8, PCI irq0
Socket status: 30000007

System hangs. Power down to recover.

I've tried reinstalling four times with the same result.

Reproducible: Always
Steps to Reproduce:
1. Install fisher using the pcmcia image.
2. System installs via ftp nicely through PCMCIA.
3. Reboot from installation and system hung on start of PCMCIA services.
	

Actual Results:  Hung system. Only way to get in is to bypass pcmcia
services startup using the Interactive option. It's weird that the system
will install nicely via PCMCIA and ftp.	

Expected Results:  PCMCIA services should have started. This is not a
problem with the old 2.2 kernel.

dmesg output:

Linux version 2.4.0-0.99.11 (root@porky.devel.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.0)) #1 Wed Jan 24 15:11:17 EST 2001
BIOS-provided physical RAM map:
 BIOS-e820: 000000000009fc00 @ 0000000000000000 (usable)
 BIOS-e820: 0000000000000400 @ 000000000009fc00 (reserved)
 BIOS-e820: 0000000000010000 @ 00000000000f0000 (reserved)
 BIOS-e820: 0000000005f10000 @ 0000000000100000 (usable)
 BIOS-e820: 0000000000010000 @ 0000000006010000 (ACPI data)
 BIOS-e820: 0000000000020000 @ 0000000006020000 (reserved)
 BIOS-e820: 0000000000080000 @ 00000000fef80000 (reserved)
 BIOS-e820: 0000000000006e00 @ 00000000ffee0000 (reserved)
 BIOS-e820: 0000000000000200 @ 00000000ffee6e00 (ACPI NVS)
 BIOS-e820: 0000000000009000 @ 00000000ffee7000 (reserved)
 BIOS-e820: 0000000000010000 @ 00000000ffff0000 (reserved)
On node 0 totalpages: 24592
zone(0): 4096 pages.
zone(1): 20496 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=linux ro root=305
BOOT_FILE=/boot/vmlinuz-2.4.0-0.99.11
Initializing CPU#0
Detected 299.946 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 598.01 BogoMIPS
Memory: 94312k/98368k available (1109k kernel code, 3668k reserved, 411k
data, 220k init, 0k highmem)
Dentry-cache hash table entries: 16384 (order: 5, 131072 bytes)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
VFS: Diskquotas version dquot_6.5.0 initialized
CPU: Before vendor init, caps: 008001bf 00000000 00000000, vendor = 0
Intel Pentium with F0 0F bug - workaround enabled.
CPU: After vendor init, caps: 008001bf 00000000 00000000 00000000
CPU: After generic, caps: 008001bf 00000000 00000000 00000000
CPU: Common caps: 008001bf 00000000 00000000 00000000
CPU: Intel Mobile Pentium MMX stepping 02
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.37 (20001109) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: none
PCI: PCI BIOS revision 2.10 entry at 0xfd60a, last bus=21
PCI: Using configuration type 1
PCI: Probing PCI hardware
  got res[10000000:10000fff] for resource 0 of Toshiba America Info Systems
ToPIC97
  got res[10001000:10001fff] for resource 0 of Toshiba America Info Systems
ToPIC97 (#2)
isapnp: Scanning for Pnp cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x02 (Driver version 1.14)
Starting kswapd v1.8
pty: 256 Unix98 ptys configured
block: queued sectors max/low 62554kB/46916kB, 192 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PCI_IDE: unknown IDE controller on PCI bus 00 device 80, VID=1179, DID=0102
PCI_IDE: chipset revision 51
PCI_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1800-0x1807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1808-0x180f, BIOS settings: hdc:pio, hdd:pio
hda: IBM-DKLA-24320, ATA DISK drive
hdc: CD-224E, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 8452080 sectors (4327 MB) w/460KiB Cache, CHS=526/255/63, UDMA(33)
Partition check:
 hda: hda1 hda2 < hda5 hda6 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is an 8272A
LVM version 0.9  by Heinz Mauelshagen  (13/11/2000)
lvm -- Driver successfully initialized
Serial driver version 5.02 (2000-08-09) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
Real Time Clock Driver v1.10d
atp.c:v1.09 8/9/2000 Donald Becker <becker@scyld.com>
  http://www.scyld.com/network/atp.html
md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
ACPI: System description tables found
ACPI: System description tables loaded
ACPI: APM is already active, exiting
md.c: sizeof(mdp_super_t) = 4096
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 8192)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 220k freed
Adding Swap: 72252k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xc701f000, IRQ 11
usb-ohci.c: usb-00:0b.0, NEC Corporation USB
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
Linux video capture interface: v1.00
V4L-Driver for Vision CPiA based cameras v0.7.4
Parallel port driver for Vision CPiA based cameras v0.7.4
Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
Winbond chip at EFER=0x4e key=0x87 devid=2d devrev=2b oldid=29
Winbond unknown chip type
SMSC Super-IO detection, now testing Ports 2F0, 370 ...
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
usb.c: registered new driver cpia
VFS: Disk change detected on device fd(2,0)
VFS: Disk change detected on device fd(2,0)
floppy0: data CRC error: track 77, head 1, sector 7, size 2
floppy0: data CRC error: track 77, head 1, sector 7, size 2
end_request: I/O error, dev 02:00 (floppy), sector 2796
Comment 1 Arjan van de Ven 2001-02-20 04:45:10 EST
*** Bug 28332 has been marked as a duplicate of this bug. ***
Comment 2 William L. Dye 2001-02-20 23:24:29 EST
The same thing happened for me.  I have a Toshiba Portege 320CT laptop PC.  I 
don't have a CD-ROM for it, just a network connection via a 10-Mbit PCMCIA 
network card.  I downloaded the beta just fine, using FTP, but the system hangs 
hard as soon as it tries to load the pcmcia service.  Cntl-alt-del doesn't 
respond -- I have to power off or hit the reset button to reboot.  It even 
happens when I don't have a PCMCIA card installed, and turn off other 
services.  Here's the tail of the dmesg, which is virtually identical to the 
one listed in this bug:

   Starting pcmcia:  PCI: No IRQ known for interrupt 
      pin A of device 00:02.0. Please try using pci=biosirq.

   PCI: No IRQ known for
      pin B of device 00:02.1. Please try using pci=biosirq.

   Yenta IRQ list 04b8, PCI irq0

   Socket status: 30000007

BTW, I'm not upset about it.  The beta download page warned me that PCMCIA was 
broke, so I wasn't counting on a clean install anyway.  The rest of the beta 
looks pretty good.  If I can get networking up, I may go ahead and keep running 
it, despite the beta status.  

Oh, and if you guys want to telnet into my machine and try some experiments on 
it, feel free to ask.  I don't have any critical or sensitive data on it -- 
it's just a test machine.  Of course, I'll need to get networking up on it 
first.  :-)

Have fun,

--Will
Comment 3 Glen Foster 2001-02-21 10:12:39 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 William L. Dye 2001-02-27 13:27:42 EST
It looks like I'll need my test machine for some work stuff, so I'm going to 
wipe the disk soon and reinstall with RedHat 6.2 or 7.0 or Debian or 
something.  Not sure yet.  Anyway, if you want me to run some tests on this 
machine, speak up now and I'll try to help.  In another day or two, I won't be 
able to recreate this PCMCIA bug any more, since I won't be running Fisher.

--Will
Comment 5 Michael K. Johnson 2001-02-28 23:23:40 EST
So far, every report we have received of a hang is with a Toshiba
notebook.  We suspect either faulty bios or faulty yenta socket.
We're testing with one Toshiba notebook, but it is quite possible
(indeed, highly likely) that Toshiba has used multiple yenta chips
and they have certainly used different bioses.

We don't have any imminent fix for this bug coming out in the next
few days.
Comment 6 Arjan van de Ven 2001-03-21 12:49:01 EST
Latest Rawhide kernels have fixes for this. Please try those and reopen this
bug if those kernels don't fix this.
Comment 7 William L. Dye 2001-03-21 13:13:19 EST
Hmm.  I have 6.2 running pretty well now, but the machine 
was put back in test status, so I suppose it's available 
for a reinstall of 7.1 now.

OK, I'll go ahead and reinstall 7.1 into my laptop PC (a 
Toshiba Portege 320CT), probably some time this week.  
To apply the fix, do I just need to reinstall the current 
7.1 from the Red Hat site?  If I need to do anything else, 
please let me know.

In all seriousness, I'd be more than happy to give you 
guys remote access and the root password to it.  That way 
you could ssh into it and snoop around yourselves, instead 
of waiting for Bugzilla reports.  This machine is mostly 
used for testing, so I wipe out the disk entirely and 
reinstall from scratch fairly often.  Let me know if you're 
interested.

--Will
Comment 8 Need Real Name 2001-06-15 16:40:13 EDT
I am trying to install RH7.1 on a Toshiba Portege 320CT and I am experiencing a 
problem similar to that above. The RH7.1 source is on our local server here and 
I want to do a FTP install via pcmcia Xircom Ce3 10/100 nic. 
I boot from the pcmcia.img disk I created, and then it asks for the driver 
disk. I give it the pcmciadd.img disk I created and then I switch over to vt 3 
(ALT-F3) and watch as it does 'going to insmod pcmcia' and then as soon as it 
displays 'going to insmod yenta socket' the machine locks up completely, no ctl-
alt-del. 

I searched for solutions on the web and tried the following suggestions from 
others:

Changed bios settings, ie. disabled com1, internal modem, lpt1, sound.
  -no effect
Passed the following options when booting from the pcmcia.img disk:
linux pci=biosirq
linux pci=irqmask=0x8fff
linux pci=irqmask=0xafff
  -no effect
Upgraded bios to latest version (8.00) and set PCI config option to 'OS config'
  -no effect
Again changed bios settings: disabled com1, internal modem, lpt1, sound.
  -no effect

I'm not sure what else to try at this point.
I'm open to any suggestions.
Regards,
Rebecca
Comment 9 per.sjoholm 2001-08-06 07:09:49 EDT
I have the same problem on a Toshiba Tecra 550CDT

I have any one found a solution ?
/Per
Comment 10 per.sjoholm 2001-08-09 04:25:01 EDT
I got it working by changing in bios, setting  pcmcia : auto-selected ->
cardbus/16 
/Per
Comment 11 Need Real Name 2001-08-25 18:12:00 EDT
Is the bug fix for the described problem in PCMCIA support (for the Toshiba
ToPIC 97 card) in the current Redhat beta (Roswell)?  I think I have run into
the bug on my Toshiba Satellite 2060 CDS after installing Redhat 7.1.  I am not
sure whether to try to upgrade my kernel and PCMCIA services to the version in
Roswell or Rawhide (as was recommended on Bugzilla - reference 28348).  It looks
like I will finally have enough time to try a kernel upgrade within the next two
weeks.  If the bug fix is in both versions of the kernel and PCMCIA, I would
upgrade to whatever is considered more stable - the current beta or Rawhide and
presumably that means the beta?  The bug fix is in Rosswell, isn't it - the
advice to use the Rawhide kernel was posted in March?
William Nicholson
Comment 12 Michael K. Johnson 2001-09-01 09:12:38 EDT
I believe the fix arjan mentioned is in rawhide but not roswell; that it
was done after roswell was cut.  rawhide is at
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/
Comment 13 Michael K. Johnson 2001-09-01 09:14:39 EDT
oops, I read a "3" as an "8" and thought arjan's comment was from
August when it is actually from March.  Must change font size...

Sounds like Per's suggestion is the right one.
Comment 14 Need Real Name 2001-09-04 14:09:15 EDT
Yes, I just checked and setting the BIOS setting for PCMCIA from auto to
Cardbus/ 16 does allow the PCMCIA card controller to be recognised and for
PCMCIA services and cardmgr to be started successfully (on my Toshiba Satellite
2060CDS).  When the ToPIC97 card controller is in Cardbus/ 16 mode, Windows 98
thinks it is a ToPIC95 (and loads up a new driver) and probe in Linux thinks it
is a ToPIC95B apparently. 
Unfortunately, although PCMCIA services start up successfully with this change,
the system crashes when I attempt to plug in any of the three cards I own (a
3com modem card, a 3com combo card and an SMC wireless card).  When I insert any
of the cards, there is a single beep and then the system hangs.  I may submit a
completely new bug report on this other problem when I have time.
Comment 15 Jan Newmarch 2003-08-18 20:46:23 EDT
This bug is still there in Redhat 9.0. It bit me on a Toshiba Satellite Pro 480
CDT, with a ToPIC97 cardbus bridge. A workaround was reported a long time ago in
http://www.michaelminn.com/linux/notebooks/toshiba335.html#section3: "This
problem can be fixed by changing the BIOS setting for the PC Card. AS THE
COMPUTER IS BEING REBOOTED OR TURNED ON, hold the <ESC> key down. The computer
will prompt you to press the F1 key - do so. This will bring up the System Setup
utility.

Press the <PgDn> key to go to page 2/2 of values. Press the Down Arrow key to
advance the cursor to the "PC CARD" Controller Mode value. It probably will be
set to "Auto-Selected". Press the space bar until it reads "CardBus/16-bit".

Then press the <End> button to exit the utility and respond "Y" when asked "Are
you sure?". The system will reboot and you should have no problems with PCMCIA
services.

Many thanks to Chad Wood for providing this fix."

Note You need to log in before you can comment on or make changes to this bug.