This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 283661 - Cleanup of today rawhide yum update has TE errors off by 1
Cleanup of today rawhide yum update has TE errors off by 1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On: 259961
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 14:44 EDT by Darwin H. Webb
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 02:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2007-09-08 14:44:46 EDT
Description of problem:
Yum update at cleanup displayed errors about ds count TE is package-name, s/b
package-name(-1) 

Version-Release number of selected component (if applicable):
IN messages
rpm-4.4.2.2-rc1.i386#000
yum-3.2.4.4.fc8.noarch#000

How reproducible:
Once is enough

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Darwin H. Webb 2007-09-08 15:20:19 EDT
This links to a forum with example of error messages in clean up.

http://forums.fedoraforum.org/showthread.php?p=861415#post861415 

Darwin
Comment 2 Jerry James 2007-09-10 23:00:49 EDT
I got one of these today, on an F7 x86 box, but it didn't kick in until the yum
transaction was nearly complete.  Note that there is no Cleanup line for
gstreamer-plugins-good-devel.

Running Transaction
  Updating  : totem-plparser               ####################### [ 1/42] 
  Updating  : GeoIP                        ####################### [ 2/42] 
  Updating  : gnome-bluetooth-libs         ####################### [ 3/42] 
  Updating  : gstreamer-plugins-good       ####################### [ 4/42] 
  Updating  : totem                        ####################### [ 5/42] 
  Updating  : rhythmbox                    ####################### [ 6/42] 
  Updating  : totem-devel                  ####################### [ 7/42] 
  Updating  : gstreamer-plugins-good-devel ####################### [ 8/42] 
  Updating  : gnome-bluetooth              ####################### [ 9/42] 
  Updating  : GeoIP-devel                  ####################### [10/42] 
  Updating  : totem-mozplugin              ####################### [11/42] 
  Updating  : perl                         ####################### [12/42] 
  Updating  : perl-libs                    ####################### [13/42] 
  Updating  : perl-Test-Simple             ####################### [14/42] 
  Updating  : perl-suidperl                ####################### [15/42] 
  Updating  : perl-Set-IntSpan             ####################### [16/42] 
  Updating  : perl-Test-Harness            ####################### [17/42] 
  Updating  : perl-CPAN                    ####################### [18/42] 
  Updating  : perl-ExtUtils-MakeMaker      ####################### [19/42] 
  Updating  : perl-devel                   ####################### [20/42] 
  Updating  : perl-ExtUtils-Embed          ####################### [21/42] 
  Cleanup   : gstreamer-plugins-good       ####################### [22/42] 
  Cleanup   : totem-plparser               ####################### [23/42] 
  Cleanup   : perl-Test-Simple             ####################### [24/42] 
  Cleanup   : perl-CPAN                    ####################### [25/42] 
  Cleanup   : totem-devel                  ####################### [26/42] 
  Cleanup   : perl-suidperl                ####################### [27/42] 
  Cleanup   : perl-Set-IntSpan             ####################### [28/42] 
  Cleanup   : perl-devel                   ####################### [29/42] 
  Cleanup   : GeoIP-devel                  ####################### [30/42] 
  Cleanup   : perl-libs                    ####################### [31/42] 
  Cleanup   : gnome-bluetooth-libs         ####################### [32/42] 
  Cleanup   : perl-ExtUtils-Embed          ####################### [33/42] 
  Cleanup   : GeoIP                        ####################### [34/42] 
  Cleanup   : perl                         ####################### [35/42] 
  Cleanup   : perl-ExtUtils-MakeMaker      ####################### [36/42] 
  Cleanup   : rhythmbox                    ####################### [37/42] 
  Cleanup   : totem-mozplugin              ####################### [38/42] 
ts_done name in te is gstreamer-plugins-good-devel should be totem-mozplugin
  Cleanup   : totem                        ####################### [39/42] 
ts_done name in te is totem-mozplugin should be totem
  Cleanup   : gnome-bluetooth              ####################### [40/42] 
ts_done name in te is totem should be gnome-bluetooth
  Cleanup   : perl-Test-Harness            ####################### [41/42] 
ts_done name in te is gnome-bluetooth should be perl-Test-Harness
Comment 3 Panu Matilainen 2007-09-11 01:40:40 EDT
This is caused by recent yum doing it's own bookkeeping on expected transaction
callback contents which mismatches with reality when packages with no files are
present as rpm doesn't currently (never has) issue callbacks on "empty" packages
during erase.
Comment 4 Panu Matilainen 2007-09-19 02:27:00 EDT
This should be fixed in current rawhide via rpm 4.4.2.2 faking the callbacks for
packages with no files.

Note You need to log in before you can comment on or make changes to this bug.