Bug 283751 - 2.6.22 broke snd-hda-intel (worked on 2.6.20), model=auto solves it
2.6.22 broke snd-hda-intel (worked on 2.6.20), model=auto solves it
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-08 17:19 EDT by Ahmed Kamal
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-10 05:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ahmed Kamal 2007-09-08 17:19:20 EDT
Description of problem:
My sound card on a Toshiba A105 was working fine on a 2.6.20, but 2.6.22 broke
it. Google told me setting the module parameter "model=auto" would solve this,
and it did :)
Now the bug is, model=auto should be the default

Version-Release number of selected component (if applicable):
Advanced Linux Sound Architecture Driver Version 1.0.14 (Thu May 31 09:03:25
2007 UTC).

How reproducible:
Every time

Steps to Reproduce:
1. Boot (or previous 22 kernels)
2. Play any sound, it doesn't work!
alias snd-card-0 snd-hda-intel
options snd-card-0 model=auto
It's weird why model=auto is NOT the default, and it's boggling, what would be
the default for the module! One would imagine, it would be "auto", even alsa
docs says model=auto is the default, but obviously it is not!
Comment 1 Martin Stransky 2007-09-10 05:41:32 EDT
Aha, so this is a bug in alsa-drivers. That should be fixed for all distros so
please file a bug at ALSA project (https://bugtrack.alsa-project.org/alsa-bug/)
and they should fix that in the new drivers release. Thanks.

Note You need to log in before you can comment on or make changes to this bug.