This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 283781 - Missing modules break iSCSI support
Missing modules break iSCSI support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On: 208607
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 21:33 EDT by Kostas Georgiou
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 13:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kostas Georgiou 2007-09-08 21:33:44 EDT
iscsiadm needs the crc32c,libcrc32c modules to work. See #208607 for details.
Comment 1 Jeremy Katz 2007-09-09 21:25:10 EDT
Reopened that bug but putting this on F8Blocker so we do something even if that
ends up being for naught.  But really, we need to handle this on the
kernel-side.  Having to special case in mkinitrd, anaconda, ... is going to suck.
Comment 2 Kostas Georgiou 2007-09-15 12:45:53 EDT
The best solution seems to solve it kernel-side yes, although since it is also
I haven't enabled crc32c digests in the target side (scsi-target-utils) you can
say that it also a bug in iscsiadm that requires the modules even if they aren't
always needed.

Anyway, as of a few days ago this is the last bug that stops iscsi working in
the installer, the following workaround in kickstart is the only thing needed
for the installation to succeed.

%pre
#!/bin/sh
cd /tmp
wget http://foo/libcrc32c.ko
wget http://foo/crc32c.ko
insmod libcrc32c.ko
insmod crc32c.ko
Comment 3 Jeremy Katz 2007-10-29 13:57:22 EDT
Kernel side fixed

Note You need to log in before you can comment on or make changes to this bug.