This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 283821 - Liberation should make Arial/TimesNR/CourierNew map to its fonts
Liberation should make Arial/TimesNR/CourierNew map to its fonts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 23:16 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 09:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-09-08 23:16:15 EDT
Description of problem:
The Liberation font set is designed to be metrically-identical to Arial, Times
New Roman and Courier New fonts. However, currently it does not configure
freetype to map the commercial fonts to their Liberation equivalent, meaning
that a user could have them installed, open a document, and still does not have
it displayed correctly.

It makes document transfer the other way difficult as well: if the user actively
selects Liberation fonts when writing the document, it won't open properly on
(e.g.) Microsoft Word, and if the user uses Times etc., it will not look the
same with the actual Times font.

Version-Release number of selected component (if applicable):
liberation-fonts-0.2-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install liberation-fonts
2. Write a document using A/TNR/CN
3. Open document on Windows
  
Actual results:
Text is aligned differently in (2) and (3) -- (2) does not use Liberation fonts

Expected results:
Text is aligned identically, (2) uses Liberation fonts

Additional info:
The fix should be pushed to F7 as well
Comment 1 Jens Petersen 2007-09-12 03:54:24 EDT
Can anything be done in OpenOffice to help with this?
Comment 2 Jens Petersen 2007-09-12 03:56:30 EDT
What fontconfig package are you using?
Comment 3 Caolan McNamara 2007-09-12 09:41:05 EDT
Well in the map other fonts to liberation direction our desktop apps should use
fontconfig to ask for fonts, and fontconfig will give liberation for the ms
equivalents.

For the other direction it is more tricky, for the case of OOo, yes we detect
liberation on export to .doc and set the equivalent ms font as the .doc fallback
font to use if liberation is not available on the windows box. That's as good as
I can do in OOo.
Comment 4 Michel Alexandre Salim 2007-09-12 09:48:04 EDT
The MS->Liberation pathway, as it turns out, is fine -- I had a local override
file I forgot to delete.

Note You need to log in before you can comment on or make changes to this bug.