Bug 283921 - synaptic shows up 3 times in KDE menu
synaptic shows up 3 times in KDE menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synaptic (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 05:51 EDT by Kevin Kofler
Modified: 2008-01-02 20:30 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.57.2-13.99.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 20:30:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-09-09 05:51:22 EDT
Description of problem:
Synaptic shows up 3 times in the KDE menu: twice under "Administration" and 
once under "System". This is due to category bloat in the .desktop file.

Version-Release number of selected component (if applicable):
synaptic-0.57.2-10.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Install Synaptic.
2. Start KDE.
3. Inspect the menu.
Alternatively, run kbuildsycoca --menutest | grep synaptic to get the 3 
entries printed to the terminal.
  
Actual results:
3 menu entries.

Expected results:
1 menu entry.

Additional info:
We analyzed this during the KDE SIG meeting and found that this is caused by 
too many categories being listed in the .desktop file.
Comment 1 Panu Matilainen 2007-09-10 01:24:45 EDT
Hmm, it shows twice in GNOME too. Settings category looks wrong, but what are
the other places in KDE it shows up?
Comment 2 Ville Skyttä 2007-09-10 12:12:56 EDT
On F7, it shows up in "System/", "Administration/More System Settings/", and
"Administration/".  Removing the (nowadays invalid anyway [0]) Application and
SystemSetup categories causes it to be show in "System/" only.

[0] http://standards.freedesktop.org/menu-spec/latest/apa.html
Comment 3 Kevin Kofler 2007-09-13 00:13:04 EDT
And as "Administration/More System Settings" and "Administration" are merged 
these days, it actually shows up twice under "Administration" and once 
under "System".
Comment 4 Axel Thimm 2007-10-26 02:35:14 EDT
So, what's the recommended setting?

Categories=PackageManager;GTK ?
Comment 5 Ville Skyttä 2007-12-29 10:07:24 EST
synaptic-0.57.2-14.fc8.x86_64 has "Categories=PackageManager;GTK;System;" and
shows up only once in my KDE menus (in System).  I think that's fine.
Comment 6 Kevin Kofler 2007-12-29 12:31:26 EST
Yes, it's fixed in the current F8 package. The problem is still there in F7 
though.
Comment 7 Axel Thimm 2007-12-30 04:38:41 EST
Once the CVS is back online again I'll submit an F7 build to get this fixed.
Comment 8 Axel Thimm 2007-12-31 08:41:14 EST
Well, I tried building this one for F-7, but it fails w/o even entering the
actual build.

This is probably unrelated to synaptic and maybe a koji bug, but in case anyone
wants to check the builds and see if I'm doing something wrong, here are the
build URLs:

http://koji.fedoraproject.org/koji/taskinfo?taskID=315439
http://koji.fedoraproject.org/koji/taskinfo?taskID=316469
http://koji.fedoraproject.org/koji/taskinfo?taskID=316514
Comment 9 Kevin Kofler 2007-12-31 09:07:25 EST
No bug there, there's no apt-devel >= 0.5.15lorg3.92 in F7 yet. You have to 
update and build apt first, then get it included in dist-fc7-override (ask 
rel-eng), then build the new synaptic.

See: http://koji.fedoraproject.org/koji/getfile?taskID=316518&name=root.log
Comment 10 Axel Thimm 2007-12-31 11:56:12 EST
Thanks Kevin, I hadn't looked at root.log as I thought that the presence of
build.log implies that the build started. :/
Comment 11 Fedora Update System 2008-01-02 20:30:30 EST
synaptic-0.57.2-13.99.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.