Bug 283941 - shows up 4 times in KDE menu
shows up 4 times in KDE menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qucs (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 06:11 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.0.12-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2007-09-09 06:11:39 EDT
Description of problem:
Qucs shows up 4 times in KDE menu.
from qucs's desktop file : 
Categories=Application;Education;Utility;X-Fedora;

Remove "Application;Education;Utility;" so that octave complies with the same 
category as that of other engineering applications.
Add: Science;Engineering instead.

Version-Release number of selected component (if applicable):
qucs-0.0.12-2.fc7


Steps to Reproduce:
1. Install qucs.
2. Start KDE.
3. run kbuildsycoca --menutest | grep qucs to get the 4 entries printed to the 
terminal.


Actual results:
4 menu entries:
chitlesh(SPECS)[0]$kbuildsycoca --menutest | grep qucs
kbuildsycoca running...
Reusing existing ksycoca
Edutainment/Miscellaneous/      
fedora-qucs.desktop     /usr/share/applications/fedora-qucs.desktop
Utilities/More Applications/    
fedora-qucs.desktop     /usr/share/applications/fedora-qucs.desktop
Administration/Utilities/More/  
fedora-qucs.desktop     /usr/share/applications/fedora-qucs.desktop
Administration/Server Settings/Utilities/More/  
fedora-qucs.desktop     /usr/share/applications/fedora-qucs.desktop

Expected results:
One menu entry on KDE menu and at "Science & Math"

Additional info:

Please fix this on rawhide as soon as possible.
Comment 1 Chitlesh GOORAH 2007-09-09 06:12:22 EDT
We analyzed this during the KDE SIG meeting and found that this is caused by 
too many categories being listed in the .desktop file.
Comment 2 Fedora Update System 2007-09-10 12:52:05 EDT
qucs-0.0.12-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-09-17 23:17:52 EDT
qucs-0.0.12-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.