Bug 28408 - Not possible to translate headers of "rpm -qi"
Not possible to translate headers of "rpm -qi"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: popt (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 06:23 EST by Göran Uddeborg
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 09:53:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2001-02-20 06:23:30 EST
The output of "rpm -qi" on this system looks like this:

Name        : rpm                          Relocations: (not relocateable)
Version     : 4.0                               Vendor: Red Hat, Inc.
Release     : 4                             Build Date: ons 30 aug 2000
23.49.43
Install date: svn  1 okt 2000 21.38.16      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM: rpm-4.0-4.src.rpm
Size        : 2853571                          License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : The Red Hat package management system.
Description :
The RPM Package Manager (RPM) is a powerful command line driven
package management system capable of installing, uninstalling,
verifying, querying, and updating software packages.  Each software
package consists of an archive of files along with information about
the package like its version, a description, etc.

The dates are translated. (and possibly mangled by bugzilla, it doesn't
seem to be 8-bit clean).  The Summary and Description would be if I was
finished with my translation of specs.po.  (I'm working on it!)

But what about the headers "Name", "Version", "Vendor" etc?  Since these
are strings in the file /usr/lib/rpm/rpmpopt-4.0 rather than in the source
code, they are not translated.  (Even though my translation of rpm is up to
date! :-)

I'm not quite sure exactly what I would like to be done.  One could of
course create a locale-specific version of the rpmpopt file, but that would
mean repeating a lot of alias "code", and would be a nuisance to maintain.

Possibly the best solution would be to extend the --queryformat with some
syntax for "translated version of", similar to the $"..." syntax of bash. 
Would that be feasible?
Comment 1 Jeff Johnson 2001-02-21 10:11:50 EST
Changing component to popt
Comment 2 Göran Uddeborg 2001-02-23 16:51:13 EST
Component "popt"?  I thought the SRPMs defined the components, and the popt
package comes from the rpm SRPM.
Comment 3 Jeff Johnson 2001-02-24 09:53:20 EST
Yes, the traditional convention is to file bugs against the src.rpm package. I'm
just resorting
my TODO tasks, popt is the place where the "fix" will be, so I've changed the
component.
Comment 4 Jeff Johnson 2001-07-25 10:04:02 EDT
I believe that popt aliases can now be i18n'ified using magic tokens
POPTdesc=$"..."
and POPTargs=$"..." in an alias file like /etc/popt, just like the corresponding
fields in poptOptions, so I'm gonna close this RFE.

Note You need to log in before you can comment on or make changes to this bug.