Bug 284141 - does not work with avahi published sound source
does not work with avahi published sound source
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 17:29 EDT by Adam Goode
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 09:37:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace on avahi crash (3.44 KB, text/plain)
2007-09-09 17:29 EDT, Adam Goode
no flags Details
pulseaudio -vv log of segfault (5.35 KB, text/plain)
2007-09-09 17:30 EDT, Adam Goode
no flags Details

  None (edit)
Description Adam Goode 2007-09-09 17:29:20 EDT
Description of problem:

If you select "Allow other machines in LAN to
browse for local sound devices", thus publishing the sound source, it segfaults
in avahi stuff.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.11.svn20070907.fc8

How reproducible:
Always.


Steps to Reproduce:
1. Start pulseaudio server.
2. Select "Allow other machines in LAN to browse for local sound devices".
  
Actual results:
D: module-gconf.c: Loading module 'module-native-protocol-tcp' with args
'auth-anonymous=1' due to GConf configuration.
I: protocol-native.c: using already loaded auth cookie.
I: protocol-native.c: using already loaded auth cookie.
I: module.c: Loaded "module-native-protocol-tcp" (index: #11; argument:
"auth-anonymous=1").
D: module-gconf.c: Loading module 'module-esound-protocol-tcp' with args
'auth-anonymous=1' due to GConf configuration.
I: module.c: Loaded "module-esound-protocol-tcp" (index: #12; argument:
"auth-anonymous=1").
D: module-gconf.c: Loading module 'module-zeroconf-publish' with args '' due to
GConf configuration.
D: module-zeroconf-publish.c: Publishing services in Zeroconf
Segmentation fault



Expected results:
Published device.
Comment 1 Adam Goode 2007-09-09 17:29:20 EDT
Created attachment 191141 [details]
Backtrace on avahi crash
Comment 2 Adam Goode 2007-09-09 17:30:01 EDT
Created attachment 191151 [details]
pulseaudio -vv log of segfault
Comment 3 Lennart Poettering 2007-09-25 09:37:15 EDT
This should be fixed in my Rawhide upload from yesterday (0.9.7-0.12.svn20070925).

Note You need to log in before you can comment on or make changes to this bug.