This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 284191 - The kernel-2.6.22.4-45.fc6 package breaks the RTC.
The kernel-2.6.22.4-45.fc6 package breaks the RTC.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 20:29 EDT by Jeff Silverman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.9-61.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 17:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Silverman 2007-09-09 20:29:46 EDT
Description of problem:
The kernel-2.6.22.4-45.fc6 package breaks the RTC. 
/proc/sys/dev/rtc/max-user-freq is not found.
sysctl -w dev.rtc.max-user-freq=1024 gives a "no such key" error message.


Version-Release number of selected component (if applicable):


How reproducible:
At will.


Steps to Reproduce:
1. Boot the kernel-2.6.22.4-45.fc6 kernel
2. use either echo 1024 > /proc/sys/dev/rtc/max-user-freq or sysctl -w
dev.rtc.max-user-freq=1024
3. 
  
Actual results:
/proc/sys/dev/rtc is not found. sysctl reports no such key.

Expected results:
It should quietly succeed.

Additional info:
The contents of the directories
/lib/modules/2.6.20-1.2948.fc6/kernel/drivers/rtc and
/lib/modules/2.6.22.4-45.fc6/kernel/drivers/rtc are different.  In particular,
/lib/modules/2.6.20-1.2948.fc6/kernel/drivers/rtc/rtc-core.ko
/lib/modules/2.6.20-1.2948.fc6/kernel/drivers/rtc/rtc-dev.ko are missing from
the /lib/modules/2.6.22.4-45.fc6/kernel/drivers/rtc.

mplayer reports that 1024 should be poked into /proc/sys/dev/rtc but that pseudo
file is missing.
Comment 1 Owen Berry 2007-09-17 16:34:40 EDT
This also creates issues for qemu:

Program output:
Could not configure '/dev/rtc' to have a 1024 Hz timer. This is not a fatal
error, but for better emulation accuracy either use a 2.6 host Linux kernel or
type 'echo 1024 > /proc/sys/dev/rtc/max-user-freq' as root.

Except that you can't set the RTC frequency due to this problem.

Kernel: 2.6.22.5-49.fc6 for i686
Comment 2 Chuck Ebbert 2007-09-28 13:27:59 EDT
Reverted to the old RTC driver in kernel 2.6.22.9-61.fc6. It will be in the
updates-testing repository soon.


Note You need to log in before you can comment on or make changes to this bug.