Bug 284281 - Ctrl-w in console closes console window
Ctrl-w in console closes console window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 01:41 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1018822 (view as bug list)
Environment:
Last Closed: 2007-10-04 22:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-09-10 01:41:30 EDT
Description of problem:
Could the close window binding (Ctrl-W) but changed to Ctrl-Shift-W
at least (assuming it is from virt-manager) since it is pretty annoying
in a shell in the console to press Ctrl-W and <woof/> the console is gone.
I actually did this by accident several times before realising what was
going on...

Version-Release number of selected component (if applicable):
virt-manager-0.4.0-2.fc7

How reproducible:
every time

Steps to Reproduce:
1. open a console window
2. press Ctrl-w (with focus in gnome-terminal say)
  
Actual results:
2. virtual console window closed

Expected results:
2. Ctrl-w to go to guest desktop

Additional info:
I wasn't able to test this with f8 (rawhide) yet - so this may be a devel
bug/rfe.
Comment 1 Daniel Berrange 2007-09-27 17:31:07 EDT
Latest upstream code now blocks all window accelerator keys when using the console

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=ef716036ca7f

Will pull into Fedora soon
Comment 2 Daniel Berrange 2007-10-04 22:32:12 EDT
Now available in rawhide in virt-manager-0.5.2 

Note You need to log in before you can comment on or make changes to this bug.