Bug 284291 - macmini driver not available
macmini driver not available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 02:00 EDT by Roland McGrath
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 16:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch adding macmini to hw_list (253 bytes, patch)
2007-09-10 02:00 EDT, Roland McGrath
no flags Details | Diff

  None (edit)
Description Roland McGrath 2007-09-10 02:00:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):
lirc-0.8.2-2.fc7

How reproducible:
100%

Steps to Reproduce:
1. /usr/sbin/lircd -H help 2>&1 | grep macmini
2.
3.
  
Actual results:

(no matches)

Expected results:
        macmini


Additional info:

Trivial patch attached.  This adds the driver (already compiled in) to the table
so you can specify it with -H.  This didn't help it actually work on my macmini,
because there is no /dev/usb/hiddev0 as it expects to find.  I have no idea what
the story is with that, but it seems like a kernel or udev problem.
Comment 1 Roland McGrath 2007-09-10 02:00:12 EDT
Created attachment 191371 [details]
patch adding macmini to hw_list
Comment 2 Jarod Wilson 2007-09-10 09:34:49 EDT
Hm... I suspect we may well need to add the appleir driver to the kernel to get
that fully working.

http://www.madingley.org/macmini/kernel/ir.patch

That's on my own todo list, just haven't got around to it yet...
Comment 3 Roland McGrath 2007-09-11 14:39:23 EDT
It looks to me as if the current lirc code does not want the appleir driver, but
only some generic usb hiddev stuff.  The documentation gives the impression
there may be nothing missing from the kernel per se.  But udev did not give me a
/dev/usb node for the built-in IR receiver (I only get one for my external USB
printer).  That might be a kernel issue (not reporting built-in USB devices to
udev?), but I have no idea really.
Comment 4 Jarod Wilson 2007-10-18 16:54:54 EDT
Indeed, no appleir driver needed. With the latest rawhide kernels, I get a
/dev/hiddev0 usb input device corresponding to the ir port on my intel mini, and
have compiled a test app from a list thread somewhere that I've misplaced, which
does confirm the kernel is seeing data from the tiny little remote.

I'm actually going to push a 0.8.3pre1 build into devel here in a sec, which
includes full support for using the apple ir port. Nb: this build won't
automagically go into F8, it'll be held back for possible inclusion in F8
updates-testing and F9 rawhide, once branched.

Note You need to log in before you can comment on or make changes to this bug.