This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 284451 - Eclipse fails to start
Eclipse fails to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 07:10 EDT by Olivier Bernard
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 09:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Corresponding error log (28.77 KB, text/plain)
2007-09-10 07:10 EDT, Olivier Bernard
no flags Details
output of rpm -qV (1.81 KB, text/plain)
2007-09-10 10:31 EDT, Olivier Bernard
no flags Details

  None (edit)
Description Olivier Bernard 2007-09-10 07:10:03 EDT
Description of problem:

Eclipse fails to start with the following error popup:

An error has occurred. See the log file
/home/olivier/workspace/.metadata/.log.

Version-Release number of selected component (if applicable):

$ rpm -q eclipse-platform
eclipse-platform-3.2.2-15.fc7


How reproducible:

Always

Steps to Reproduce:
1. $ eclipse
2. Error message appears and eclipse fails to start
Comment 1 Olivier Bernard 2007-09-10 07:10:04 EDT
Created attachment 191551 [details]
Corresponding error log
Comment 2 Andrew Overholt 2007-09-10 09:29:53 EDT
Can you please paste the output of:

for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done

?  Thanks.
Comment 3 Olivier Bernard 2007-09-10 10:31:00 EDT
Created attachment 191691 [details]
output of rpm -qV
Comment 4 Andrew Overholt 2007-09-10 10:43:18 EDT
Well now we know why it won't start :)  It looks like your libswt3-gtk2 RPM is
broken.  Try re-installing it and seeing what happens.
Comment 5 Olivier Bernard 2007-09-11 05:36:42 EDT
Thanks for all, now it works :)
Comment 6 Andrew Overholt 2007-09-11 09:06:12 EDT
Cool.

Note You need to log in before you can comment on or make changes to this bug.