Bug 284541 - SELinux is preventing modprobe (insmod_t) "setsched" to (kernel_t).
SELinux is preventing modprobe (insmod_t) "setsched" to (kernel_t).
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 08:56 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 16:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-09-10 08:56:28 EDT
Description of problem:
I am getting messages like that during boot and shutdown:
avc: denied { setsched } for comm="modprobe" pid=820
scontext=system_u:system_r:insmod_t:s0-s0:c0.c1023 tclass=process
tcontext=system_u:system_r:kernel_t:s0 
avc: denied { setsched } for comm="modprobe" pid=1548
scontext=system_u:system_r:insmod_t:s0 tclass=process
They differ from time to time, but the general form stays the same. The two
above were grabbed with setroubleshoot from /var/log/dmesg.

Version-Release number of selected component (if applicable):
2.6.4-40.fc7

How reproducible:
always

Steps to Reproduce:
1. boot up the pc, or shut it down
  
Actual results:
The mentioned message appears

Expected results:
Boot is clean

Additional info:
According to [1], this was already fixed for rawhide. Looks like the fix wasn't
backported, though.

[1] http://www.redhat.com/archives/fedora-selinux-list/2007-July/msg00110.html
Comment 1 Daniel Walsh 2007-09-10 10:06:54 EDT
Fixed in selinux-policy-2.6.4-42.fc7
Comment 2 Julian Sikorski 2007-09-10 11:44:28 EDT
I guess I need to wait a bit until it gets built - cvs/koji is at 2.6.4-41.fc7
ATM. Still, thanks for the quick response.
Comment 3 Julian Sikorski 2007-09-11 04:44:59 EDT
Erm, the build was cancelled. What is going on?
Comment 4 Julian Sikorski 2007-09-11 16:48:00 EDT
The fix indeed works. Thanks.

Note You need to log in before you can comment on or make changes to this bug.