Bug 284771 - RFE: pvmove: give better diagnostic for invalid "-n LV" name
RFE: pvmove: give better diagnostic for invalid "-n LV" name
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 12:30 EDT by Jim Meyering
Modified: 2013-03-13 16:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.02.34
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 10:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
show pvmove's misleading diagnostic (1.28 KB, application/octet-stream)
2007-09-10 12:30 EDT, Jim Meyering
no flags Details
Proposed patch (2.82 KB, patch)
2008-04-03 11:50 EDT, Milan Broz
no flags Details | Diff

  None (edit)
Description Jim Meyering 2007-09-10 12:30:52 EDT
Description of problem:
I was following an example from a non-RH (or old?) version of the pvmove man
page (http://linux.about.com/library/cmd/blcmdl8_pvmove.htm), that suggested
using pvmove's "-n vg_name:PE" option, e.g., "-n vg1:0".  However, using a PE
range there is not valid, and makes pvmove complain, just as if one had
specified any invalid VG name.  FWIW, the PE range must be appended to the
source or dest device name.

Version-Release number of selected component (if applicable):
LVM version:     2.02.27 (2007-07-17)

How reproducible:
see attached script

Steps to Reproduce:
1. run the script, and note the "No data to move for vg-pvmove-demo" diagnostic
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jim Meyering 2007-09-10 12:30:52 EDT
Created attachment 191761 [details]
show pvmove's misleading diagnostic
Comment 2 Milan Broz 2008-04-03 11:50:39 EDT
Created attachment 300272 [details]
Proposed patch
Comment 3 Milan Broz 2008-04-04 08:00:34 EDT
Patch is in upstream cvs.
Comment 4 Jon Stanley 2008-04-23 16:30:03 EDT
Adding FutureFeature keyword to RFE's.
Comment 5 Milan Broz 2008-07-31 10:38:09 EDT
This is already fixed in rawhide since lvm2 2.02.34.

Note You need to log in before you can comment on or make changes to this bug.