Bug 28479 - [aic7xxx] kernel panic occured when adaptec scsi is accessed
[aic7xxx] kernel panic occured when adaptec scsi is accessed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 12:51 EST by Bill Huang
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 16:32:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic when access to scsi (613 bytes, patch)
2001-02-20 12:53 EST, Bill Huang
no flags Details | Diff

  None (edit)
Description Bill Huang 2001-02-20 12:51:44 EST
(Originally reported by Hitachi)

Test machine: 8wayIA-64

Bug:Adaptec SCSI driver

Reason:
The new version 6.08BETA of the driver is used in Fisher,actually in this
version,
since distributed commands are too many,buffer(SW IO TLB) of kernel became
not enough and kernel got panic.

Soultions:
Change the default number of distributed commands from 254 to 3.
The patch is attached.
Comment 1 Bill Huang 2001-02-20 12:53:06 EST
Created attachment 10540 [details]
kernel panic when access to scsi
Comment 2 Glen Foster 2001-02-21 10:05:06 EST
This defect is considered MUST-FIX for Florence Release-Candidate #2
Comment 3 Michael K. Johnson 2001-02-21 12:51:17 EST
Please test with wolverine kernel and both aic7xxx and aic7xxx_new
drivers and report any problems with either driver.
Comment 4 Bill Huang 2001-02-21 15:30:09 EST
understood.
Comment 5 Bill Huang 2001-02-21 16:30:36 EST
Excuse me,which version do you mean?There seems no aicxxx_new included in
Wolverine version.

bash-2.04$ rpm -qlp kernel* | grep aic
/lib/modules/2.4.1-0.1.9/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9BOOT/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9enterprise/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9smp/kernel/drivers/scsi/aic7xxx.o
/lib/modules/2.4.1-0.1.9smp/kernel/drivers/scsi/aic7xxx.o

bash-2.04$ pwd
/mnt/test/wolverine/i386/RedHat/RPMS

and the test platform is IA64.....
Comment 6 Bill Huang 2001-02-21 16:32:35 EST
Sorry,you mean in rawhide..
Comment 7 Doug Ledford 2001-02-21 18:38:44 EST
The patch to change the aic7xxx queue depth is the *wrong* thing to do here. 
You need to fix the core ia64 kernel code, the aic7xxx driver isn't doing
anything wrong.  If needed, someone should take this problem to the ia64 mailing
list and have the kernel people there write a proper fix.  I'm closing this bug
out since it isn't an aic7xxx problem, someone should open a new bug against the
ia64 kernel that the DMA mapping code uses an insufficient map table size and
doesn't dynamically expand it as needed.

Note You need to log in before you can comment on or make changes to this bug.